Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Uniconverter is a command-line tool that shares code with the sK1 Project. it's used to convert from one type of vector graphic file to another like this:

uniconverter before.eps after.svg

I'm looking for a step by step solution to install this tool on my laptop.

A similar question posted on the Uniconverter Forum back in August is still unanswered.

I read about Uniconverter in an answer posted by Neil but don't grok how to send him a message directly for more details.

share|improve this question
I don't think it was ever meant to be installed on OS X because it has a few dependencies … you'd have to compile it from source anyway. I dropped Nell a comment with a link to your question. –  slhck Jan 5 '12 at 8:09

3 Answers 3

I have Lion with MacPorts installed packages.

I will describe here all what I did to make compilation work. May be some steps are unnecessary, maybe some additionnal libraries will have to be installed (using MacPorts) prior to sk1libs or uniconvertor compilation to make it work.

My answer is based on @bitboxer's answer with some additions.


I used the links provided here: http://sk1project.org/modules.php?name=Products&product=uniconvertor&op=download

Downloaded and extracted uniconvertor and sk1libs

sk1libs installation

First try

I first ran the following:

$ export LDFLAGS="-L/usr/X11/lib"
$ export CFLAGS="-I/usr/X11/include -I/usr/X11/include/freetype2 -I/usr/X11/include/libpng15"
$ python setup.py build

Please notice that the libpng version is 15 (not 12 as in @bitboxer's answer). I noticed this searching in /usr/X11/include directory.

Which gave some errors:

ld: library not found for -llcms
collect2: ld returned 1 exit status
ld: library not found for -llcms
collect2: ld returned 1 exit status
lipo: can't open input file: /var/folders/3w/5x6f3w0n4rg0w6sdq2n_48j00000gn/T//cc8y3Erh.out (No such file or directory)
error: command 'llvm-gcc-4.2' failed with exit status 1


So I tried to figure out if I had already lcms library installed:

$ locate lcms

lcms was installed by MacPort on my computer (lcms seems to be a dependency of Inkscape).

Second try: success

So I did this:

$ export LDFLAGS="-L/usr/X11/lib -L/opt/local/lib/"
$ export CFLAGS="-I/usr/X11/include -I/usr/X11/include/freetype2 -I/usr/X11/include/libpng15 -I/opt/local/include"

Which added the MacPorts include and lib dir to compilation flags.


$ python setup.py build

Which ended with no errors (but some warnings).


$ sudo python setup.py install

Uniconvertor installation

Same thing (I ran it just after sk1libs compilation, so LDFLAGS and CFLAGS value are the same):

$ python setup.py build
$ sudo python setup.py install
share|improve this answer

Download sk1libs and uniconvertor and extract it. Open Terminal.app and go into the sk1libs dir. Execute this:

export LDFLAGS="-L/usr/X11/lib"
export CFLAGS="-I/usr/X11/include -I/usr/X11/include/freetype2 -I/usr/X11/include/libpng12"
python setup.py build
sudo python setup.py install

After that go into the uniconvert dir and do the same. That should do the trick.

You may get an error like this:

In file included from src/imaging/libimagingft/_imagingft.c:31: /usr/local/include/ft2build.h:56:10: fatal error: 'freetype/config/ftheader.h' file not found

You can fix it with symbolic link - execute this command:

sudo ln -s /usr/local/include/freetype2/freetype/ /usr/include/freetype
share|improve this answer
I failed to install sk1libs. I got 0.9.1. First, you have unnecessary space between '-' and 'I' an second command. Second, there wasn't /usr/X11/include/libpng12 folder on my computer but was /usr/X11/include/libpng15. After being corrected to libpng15 build finished with error src/pycms/_pycms.c:21:10: fatal error: 'lcms.h' file not found. What would you suggest? –  Valeriy Van Feb 7 '13 at 12:58
I fixed the lcms.h error by creating a /usr/local/include/freetype symlink: ln -s /usr/local/include/freetype2 /usr/local/include/freetype –  Koen. Mar 31 at 10:30

Today I have successfully installed UniConvertor on my Snow Leopard:

  1. Downloaded it from softpedia
  2. Uncompressed the tar.gz to a ~/tmp/uniconvertor-1.1.5
  3. Opened a terminal and cd ~/tmp/uniconvertor-1.1.5/
  4. sudo python setup.py install or su to a root shell and python setup.py install

And now it works like charme.

share|improve this answer
Can you verify this works in Lion? –  JoshP Oct 10 '12 at 17:19
I don't have Lion unfortunately –  Attila Fulop Oct 10 '12 at 17:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.