Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Since I upgraded my Debian 'testing' with an apt-get dist-upgrade yesterday (Wed Jan 6th 2012), I cannot mount anymore a Windows share.

The share is still available, as I can connect to it using another Debian 'testing' system that I've not upgraded since end of Nov 2011.

The share used to be automatically mounted using /etc/fstab and has worked for years.

//server/share  /xfer  cifs  soft,credentials=/home/user/.smb_cred

What has changed in mount.cifs that disallows this?

It is not working anymore neither running mount in a root shell, nor using smbclient.

The error message:

# mount -t cifs //server/share /mnt -o user=username
mount error(115): Operation now in progress
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
#
share|improve this question
    
Saying "cannot" is about as useful as telling your doctor "something somewhere hurts". Please give the exact results and error messages if any. –  grawity Jan 5 '12 at 10:22
    
It's as useful as the "mount error(115): Operation now in progress" error message that mount.cifs is returning, @grawity. It's almost as useful as one of MSFT's $large_hex_number error messages. Errno 115 is well-described at stackoverflow.com/questions/10204134/… by @ gsbabil But, what is REALLY means is "I couldn't contact the host" - one would think that the writers of said code would give a more illuminating error message. –  Andrew Beals Apr 25 '12 at 22:02
    
My guess is that when Didier upgraded, it came with new firewall rules blocking port 445 (and/or 139) were silently added to his linux server's configuration. He should be able to see tcp traffic flow out of his network port towards the windows box. I'd wager that he's not seeing that. –  Andrew Beals Apr 25 '12 at 22:05
1  
@AndrewBeals: I posted my comment two hours before "Errno 115" was added to the question. –  grawity Apr 25 '12 at 22:07

1 Answer 1

Going by Mounting a Windows computer with two IP addresses, apparently one possible cause for this is that SERVER maps to more than one IP address, possibly on different interfaces (remember that there may be virtual interfaces created). You could check this using nmblookup and as per that post either disable NetBIOS-over-TCP/IP on the second NIC, or just try using the IP address directly.

You may also want to check out Debian bug #654701: cifs-utils: Windows share cannot be mounted anymore after dist-upgrade on wheezy (5.1 -> 5.2) which reports on a seemingly very similar (or perhaps identical) problem after a recent system upgrade bringing in cifs-utils 5.2.

In general, while it isn't unstable, Debian testing is meant for testing. Some breakage is to be expected there, IMO, and part of running it is reporting issues found to the package maintainers so they can be fixed before things make their way to stable. (It's unstable/sid -> testing -> stable.)

share|improve this answer
    
I did submit the Debian bug today: that's why it is exactly the same issue! Regarding Debian testing, I know. I use it daily, performing upgrades on a regular basis. I've been doing this for years, and don't complain: I know what I'm doing. Just want to understand and fix the issue before it spreads further. –  Didier Trosset Jan 5 '12 at 14:15
    
I've already tried to use the IP address directly. Doesn't work. –  Didier Trosset Jan 5 '12 at 14:16
    
nmblookup reports name_query failed to find name server. I remember our IT guy telling me that NetBIOS had been removed with the latest Windows servers deployment in the last months. But even if it is linked to tho mount not working, note that cifs 5.1 still works on another system. –  Didier Trosset Jan 5 '12 at 14:19
    
@DidierTrosset, my apologies, I'm still not quite used to it being January again! –  Michael Kjörling Jan 5 '12 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.