Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Cygwin under Windows 7. For some reason (*) Cygwin talks to me in Japanese: bash responses, error messages from g++ etc are in Japanese. I speak some Japanese but having C++ compiler error messages in Japanese is a bit too annoying. In the DOS-Box-based bash, I can see at least the Japanese characters of the error messages, in xterm only latin characters are displayed.

How can I set Cygwin back to English?

(*) I am running a english version of Windows 7, however I do have various windows Japanese software installed, and my language for non-unicode programs is set to Japanese encoding for this reason. I do not know if this related.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Try updating Cygwin by running setup.exe. A few months ago a change was made to Cygwin's internationalization library that caused it to default to the language set on the Formats tab of the Windows Regional&Language control panel. This was later reverted.

If that's not the problem, then I guess the locale is set to Japanese, via one of the LC_ALL, LC_MESSAGES, or LANG variables. In Cygwin's default terminal (i.e. mintty) the locale can be set on the Text tab of its options.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.