Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a MacBook Pro running Mac OS X Lion which has a single local user (the local administrator account that I setup) and then the domain user setup on the laptop.

I've gone into "Login Options" under System Preferences > Users & Groups and set the option "Display login window as: Name and password".

When the laptop first boots, it has automatically selected the local admin account, and I don't see where I have the option to change users. However, when if I log into that local administrator account and then log out (without rebooting) it will allow me to enter the user and password.

share|improve this question

5 Answers 5

It sounds like you have automatic login turned on. You should be able to turn it off via the following steps:

  1. Click the Apple menu in the top left hand corner of the screen and click System Preferences.
  2. Click on the "Security and Privacy" panel in the "Personal" section.
  3. Click the lock icon in the bottom left hand corner of the window to unlock the control panel so that you can change options.
  4. Enter your password in the popup window to authorize the unlock.
  5. Check the "Disable Automatic Logon" option.
  6. Close the window to save changes.
share|improve this answer
    
This seemed promising but when I go to that option it has "Disable automatic" already checked, and it is grayed out as well so I couldn't even unselect it if I wanted to...ever seen that? –  Windows Ninja Jan 5 '12 at 14:51
    
did you click the lock at the bottom to unlock the control panel so that you can make changes? I would also recommend taking a look at David DelMonte's solution. –  Brent Hunter Jan 5 '12 at 14:56
    
You should be able to uncheck it, there is a lock at the bottom that says "Click the lock to make changes". As long as you are an admin account you should be able to authenticate and unlock the screen to edit the options there. –  Paperlantern Jan 5 '12 at 15:00
    
I did unlock it but that option was still grayed out. I'm thinking this may have something to do with GPOs setup on our Windows domain since this Mac is joined to it. –  Windows Ninja Jan 5 '12 at 15:07
    
Welcome to Super User! We generally prefer you post the answer here, instead of just linking. If you just hit EDIT on your post, it'd be awesome if you could give us a short summary of what to do. –  Simon Sheehan Jan 5 '12 at 15:38

Most likely Automatic Login is still enabled. Apple Menu -> System preferences -> Accounts -> Login Options -> Automatic Login -> Off

share|improve this answer

I use this method. System Prefs > Users and Groups.

That brings up this window:

enter image description here

Unlock to make changes > login options >

Turn off Auto login.

You can see if you prefer List of Users or Name and Password.

I also like to use Fast user switching.. Try it..

share|improve this answer

This is a limitation when you have FIlevault turned on (and your boot drive is encrypted). Only Administrators can decrypt the drive, so Standard users won't be able to login until then.

share|improve this answer

I found that going into FileVault (make sure your logged in with the user that that performed FileVault) and Enabling the user fixed the issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.