Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have UPC internet connection (chello.pl).
My router is D-Link DIR-300.
When I use provided modem to connect to the internet there is no problem. When I try to do it via router, I can't get a connection. I can log in to router and change its settings but the router does not "see" the internet. I set connection type to dynamic IP address (DHCP).

In diagnostic mode on WAN cable I get:

TxPair Short Cable at 15 meters
RxPair Error at 15 meters
(note: no longer an issue)

How can I establish a proper connection?

EDIT:
ISP -----[concentric cable]----- modem -----[ethernet cable]----- PC (that works)
ISP -----[concentric cable]----- modem -----[ethernet cable]----- router -----[ethernet cable or wifi]----- PC (that doesn't work)

My modem is Scientific Atlanta model EPC2203 Cable Modem/EMTA.

ipconfig /all while connected without router (sorry it's not in English)

Konfiguracja IP systemu Windows

   Nazwa hosta . . . . . . . . . . . : PPC
   Sufiks podstawowej domeny DNS . . :
   Typ węzła . . . . . . . . . . . . : Mieszany
   Routing IP włączony . . . . . . . : Nie
   Serwer WINS Proxy włączony. . . . : Nie
   Lista przeszukiwania sufiksów DNS : chello.pl

Karta bezprzewodowej sieci LAN Połączenie sieci bezprzewodowej:

   Stan nośnika . . . .  . . . . . . .: Nośnik odłączony
   Sufiks DNS konkretnego połączenia :
   Opis. . . . . . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
   Adres fizyczny. . . . . . . . . . : 00-25-D3-DC-23-9F
   DHCP włączone . . . . . . . . . . : Tak
   Autokonfiguracja włączona . . . . : Tak

Karta Ethernet Połączenie lokalne:

   Sufiks DNS konkretnego połączenia : chello.pl
   Opis. . . . . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Adres fizyczny. . . . . . . . . . : E0-CB-4E-08-CE-97
   DHCP włączone . . . . . . . . . . : Tak
   Autokonfiguracja włączona . . . . : Tak
   Adres IPv4. . . . . . . . . . . . . : 89.74.136.19(Preferowane)
   Maska podsieci. . . . . . . . . . : 255.255.252.0
   Dzierżawa uzyskana. . . . . . . . : 6 stycznia 2012 15:06:02
   Dzierżawa wygasa. . . . . . . . . : 8 stycznia 2012 12:30:16
   Brama domyślna. . . . . . . . . . : 89.74.136.1
   Serwer DHCP . . . . . . . . . . . : 62.179.2.134
   Serwery DNS . . . . . . . . . . . : 62.179.1.62
                                       62.179.1.63
   NetBIOS przez Tcpip . . . . . . . : Włączony

..

Screenshots of router setup while connected to the modem:

Internet Setup

Advanced Network

System Check

Status when connected via modem:

Status

share|improve this question
1  
If you want to use your router ( I assume you mean modem ) your going to have to spoof the MAC address of the provided modem. –  Ramhound Jan 5 '12 at 15:35
    
I meant both. I have a modem provided by ISP and my own wireless router (D-Link DIR-300). I connect this modem to concentric cable and then my router to the modem via ethernet cable. –  Jan Ajan Jan 5 '12 at 15:37
1  
Have you tried a different cable between modem and router? –  RedGrittyBrick Jan 5 '12 at 15:54
    
Yes I tried. Didn't help. Those cables worked very well in scenario without router. But why both cables get TxPair Short Cable and RxPair Error ? –  Jan Ajan Jan 5 '12 at 15:55
    
Did you make the cables? –  horatio Jan 5 '12 at 16:13
show 2 more comments

3 Answers

Have you shut down the modem and router and then restarted the modem and allow it to fully boot and then restart the router? Have see an issue whwrere modem is "bound " to the MAC of the computer at setup. Have seen this when changing routers as well. Have also seen cases in Canada where the ISP has to make a change to allow a different MAC. Sometimes waiting 24 hours without modem connected works if DHCP lease is short.

Have also seen D-Link modems that need to have the speed on the WAN port set manually. default is auto and some modems do not work well this way. On the D-link firmware I have it is on the Advanced tab and then Advanced Network. You can pick from 10Mbps, 100Mbps, 1000Mbps or Auto. Try each one and see what you get

Your router should also be able to Spoof the MAC of the computer and that may be needed if above does not work. There is a button on the Manual Internet setup page "Copy your PC's MAC Address" that makes this easy.

share|improve this answer
    
I tried shutting down and restarting everything several times without success. I'll try this speed setting. –  Jan Ajan Jan 5 '12 at 15:45
    
My ISP will fail to assign a new address for as long as one hour. Makes troubleshooting difficult. –  horatio Jan 5 '12 at 16:13
    
ISP's seem to be unhelpful anywhere in the world. –  Dave M Jan 5 '12 at 19:40
add comment

Many modems will not recognize the new MAC address when you change to the router. Some will reset after some period of time, and others have to be reset manually. The can be done by cycling the power. There are modems in the U.S. that have a battery (for 911 service) which you can't power cycle. Those have a reset button on the back for this purpose.

share|improve this answer
    
Tried shutting down, disconnecting from power and restarting with button. Both router and modem. No success. –  Jan Ajan Jan 5 '12 at 15:46
add comment

If you didn't follow the setup wizard, I'd suggest you try that first.

If that doesn't work then you are likely going to have to set it manually. Therefore, view your network connection on your PC while connected directly to the modem in order to get the primary and secondary DNS server IP addresses. Also, if the MTU is available make note of it.

Once you have that info, connect your router and enter the administrative software. This is done by entering the router's IP address (typically default is 192.168.0.1) in a browser. Once in there, you can setup the Internet connection manually. Below is a screen shot of that. Also, make sure you click to copy your PC's MAC address. This will allow the modem to think it is connected to your PC again.

Screen Shot

Remember to save settings before you close the window. This will restart the router.

share|improve this answer
    
I tried setup wizard and manual settings. Didn't help. –  Jan Ajan Jan 6 '12 at 15:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.