Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Thunderbird 9.0.1 and iOS (iPhone 4S) connected to the same IMAP account on a Dovecot server.

When I delete emails from Thunderbird, they no longer show up on the iPhone. So far so good.

When I delete emails from the iPhone, the emails still show up in Thunderbird. I've tried waiting up to an hour after I've deleted the emails from my iPhone, but the emails I deleted still show up in Thunderbird. I've tried clicking the "Get Mail" button, but deleted emails still show up in Thunderbird. The only remedy I've found so far is to quit and restart Thunderbird, which is inconvenient.

Up until just recently, I used Apple's desktop, and emails deleted on the iPhone disappeared immediately from desktop

What's wrong?

share|improve this question
I have the same problem with iphone and thunderbird on windows. nhutto's answer doesn't fit because doesn't explain why quitting thunderbird on mac/pc and restarting it resolves the problem. Any other ideas on how to fix this? Seems like a bug in the desktop app - not correctly picking up the deletions. – user119341 Feb 20 '12 at 23:53

Some background in

It is perfectly appropriate for a deleted message in a IMAP account to be visible in webmail or other email clients. Deleting a message just sets a flag, and it's up to the GUI what it should do when there is a message with that flag set. However, once Thunderbird compacts (expunges) that folder, the deleted message shouldn't be visible any more from webmail or any email client because it has been physically deleted.

You can set Dovecot to notify clients like Thunderbird that there have been changes to the folder. I found a description of the solution here:

They say that the CONDSTORE capability is the problem. You should remove CONDSTORE (and also QRESYNC, since it implies CONDSTORE).


$ telnet localhost 143
telnet> a login user pass
telnet> b capability

ctrl-] q to get out of telnet session

Take the string you got, remove CONDSTORE and QRESYNC, set "imap_capability" to this value in /etc/dovecot/dovecot.conf.

Mine ended up being this:

share|improve this answer
Right. But the problem is that I have Thunderbird configured to hide deleted messages, yet messages flaged as deleted by other IMAP clients still show up in Thunderbird. – smokris May 10 '12 at 20:44

This has bugged me for a year but one google search sorted it. I could kick myself!

The dovecot config change has fixed my issue, which is exactly as described by the OP, except mine is iPhone5.

On my Dovecot (v2.0.9) I just had to alter /etc/dovecot/conf.d/20-imap.conf as suggested, then "service dovecot restart" and the infuriating deleted-but-not issue is gone forever :)

share|improve this answer

check the setting on your iphone my bet is it does not remove from the imap server just on its self so you have a better archive on the server. I would look into all of the setting on the iphone app and also check on your server to see if it has a default action for delete.

share|improve this answer
Thanks. iOS seems to be flagging the messages as deleted (according to the IMAP protocol), but Thunderbird doesn't seem to be acknowledging this until after I restart. Apple desktop, as well as PINE/Alpine, both interpret the iOS's email deletions as I expected. – smokris Jan 6 '12 at 3:00

Was having the same problem and this fixed it for me!

In Thunderbird right click on the inbox, then select properties. Under the general information tab at the bottom is a box that says "Sometimes the folder index (.msf) file becomes damaged and messages may appear missing or deleted messages continue showing; repairing the folder may fix these issues." click Repair Folder.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .