Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've had the Logitech Wave MK550 for about two years now, and it has acted up twice on me now. Now being the second time, anyways. What is happening is the mouse and keyboard simply stop working on my computer, however, they work on the same computer on Arch linux, Ubuntu, on my laptop running Windows 7, Arch and Ubuntu as well.

I talked to Logitech tech support today, but that didn't go anywhere. We determined that Windows is finding the devices and installing the drivers appropriately, because they show up in the Device Manager. My PS/2 Keyboard works fine, along with another USB mouse that I am using in the meantime, so she really had no idea where to direct me.

Anyone have an idea as to where to go from here? I miss my keyboard

share|improve this question
    
Your not alone, I must ask is it an asus board? one person believed that it effected them more often. First must cleanup the device list and leftover hids Do the whole "Hidden Devices" tweak, then go into device manager, and select View Show Hidden Devices And get rid of the repeated ghost items in there, then reboot, and let it finish reinstalling anything important. –  Psycogeek Jan 6 '12 at 2:33
    
You got it! I'm on an Asus Rampage mobo. I'll try this out when I get home from school today, hopefully it works. You should probably put that as an answer :P –  Tanner Jan 6 '12 at 15:01
    
@Psycogeek Unfortunately, it didn't work. I removed all the hidden devices from Keyboards, Mice and other pointing devices, and HID compliant devices. Are there any others I need to remove? –  Tanner Jan 6 '12 at 20:09
    
yes clean up everything that is ghosted for being a repeat, or is no longer used at all ones you know. I have only one registry item So far, that sets how long a mouse/Key driver Hook is allowed to Hangup , win7 system being protective of bad driver. [HKEY_CURRENT_USER\Control Panel\Desktop] "LowLevelHooksTimeout"=dword:00002710 <-- time before it drops it. Because this doesnt happen on XP (as often) there has to be another parameter like the hooks for simple drivers that windows thinks hangs too ?? i have not found it. –  Psycogeek Jan 6 '12 at 22:37
    
Other possibilities, some kind of sleeping/standby going on, Try changing power managment of the whole device connection layer to that device? ?I would like to know how this Shows up in the devices, when it happens? does the item drop out, or is it an additional piece of software that the mouse/key uses? –  Psycogeek Jan 6 '12 at 22:44

3 Answers 3

up vote 4 down vote accepted

Well, solved it myself. The problem had nothing to do in the end with the fact I am on an ASUS motherboard, it stemmed from the fact that I had MotionJoy drivers installed for using a Playstation 3 controller over USB. That works fine, however, the MotionJoy driver package also contains drivers for internal and USB bluetooth dongles, and Windows randomly decided to use the MotionJoy drivers for my mouse and keyboards USB receiver.

I solved it by going to the Control Panel -> Devices and Printers. Under the 'Unknown Devices' heading there was the USB receiver. Right click -> Properties -> Hardware -> Select HID Compliant Device -> Properties -> Under the General Tab, Change Settings -> Driver Tab, click Uninstall Driver, and check Delete this driver. Click OK, and restart the system.

Let me restate, this is only applicable if your USB mouse or keyboard is not working, and you have the MotionJoy drivers installed on your system. I didn't look for a workaround, because I do not use my PS3 controller on the computer anymore.

share|improve this answer
    
Thanks dude, this helped resolve my problem as well. –  Pranav Jituri Mar 20 at 16:25
    
@PranavJituri glad to know, it was a real pain to figure out. –  Tanner Mar 25 at 15:02

Just thought I would pass this on, especially since I think this is an issue that is really not necessarily dependent on the hardware type, and/or the the HID drivers. It is just a guess but I am thinking that it may be a combination of anti-virus/malware software people run that is possibly corrupting the drivers and or services for HID touchpads and or HID mouse.

I have an Asus g73sw laptop running Windows 7. Uninstalling all USB drivers in the Device Manager and then clicking Check for hardware changes, worked but only for a little while. Here is what did work:

Click:

  1. Start
  2. Run
  3. Type: msconfig
  4. On the General Tab, click Diagnostic Startup
  5. then click Selective startup, choose only Load system services and clear the check marks from Load startup Items and Use Original Boot configuration
  6. Click Apply, and when it prompts to restart computer now? click yes
  7. After the computer reboots, log in of course and try out your USB mouse
  8. Mine worked at this point; I hope this works for you too!
  9. Repeat steps 1 through 3. Once there put all the check marks back and then select Normal startup, click apply and yes to restart computer
  10. Try your USB mouse again - it should be working with "refreshed" HID drivers

Hope this works for you! The only thing I can think of is that sometimes updates may break the HID USB Hubs and HID compliant device drivers, or some service is interfering with the load order. I can't tell you exactly why this works, I just know that today I gave my USB, Mouse and Synaptics Touchpad a SERIOUS gaming workout, complete with frequent boots and device removal today and I have had ZERO problems for a straight 8 hours or more!

No reinstalling, mouse, driver, OS, regedit, Fix It, nothing - just the method above FINALLY resolved my "disappearing", code 10 code 43, device not recognized, driver failed to install mouse issues.

Msconfig is very powerful so use with caution. If you don't know what it is, read this:

http://support.microsoft.com/kb/310560

share|improve this answer

Problem

On Windows XP SP3, USB mouse is recognized as HID-Compliant device under Human Interface Devices category. The mouse does not work.

Solution

Go to the wrong device in Device Manager and manually change it to HID-Compliant mouse:

  1. Connect a functioning mouse such as a PS2 mouse
  2. In Device Manager expand Human Interface Devices
  3. Right-click HID-Compliant device
  4. Click Update Driver... -> No, not this time -> Next -> Install from a list or specific location (Advanced)** -> Next -> Don't search,I will choose the driver to install -> Next
  5. Select HID-Compliant mouse, then click Next and then Finish
  6. Connect the USB mouse to the next USB port, and do the same again.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.