Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Windows XP x32 laptop with Intel Wireless Pro 2200BG chipset.

This laptop is run 24/7 as a home server system, I have previously had this connected to a wired 10/100 network and would never disconnect from the router. However as I can no longer run a cable easily I have changed the server to run over wireless 802.11g network.

However after a certain period of inactivity the system will disconnect from the wireless network until the system is awoken by keyboard or mouse interaction, making it not quite a server any more.

The system is always running and will never go into standby and the power management on the chipsets drivers is set to maximum performance.

Is there any way to nail up this connection?

share|improve this question

2 Answers 2

up vote 0 down vote accepted

I forgot to mention that I was connecting to the device via Remote Desktop.

When Remote Desktop disconnects from the computer is is the equivalent of "Switch User" which partly logs out the user.

The Intel Wifi profile has an advance property to allow the computer to keep the wifi connection enabled after logoff, this needs to be enabled. However on top of that by disabling "Fast User Switching" the connection now remains active at all times and does not log off the network.

share|improve this answer

Go into the Device Manager, find the wireless device, Doubble click on it, Go to the Power Management tab Uncheck [ ] Allow this computer to turn off this device to save power

While your still in there, check any advanced tab, which will show the devices own advanced driver options , just in case there is something in them that would be important for this.

If you can not easily find the device manager, just paste this into RUN DevMgmt.msc

If that still doesn't work, go back to device manager, In the menu View select Device by connection, find the wireless device again, follow the connection chain back, from the device, and set the same Power managment options for any parts of that connection chain (if they exist). Like here, it would include a USB hub with power managment ability.

share|improve this answer
1  
There is no Power Management tab anywhere along the chain, neither any setting in the bios. –  JProgrammer Jan 6 '12 at 4:49
    
ok, were there any PM settings in device manager, for the wireless device? . . . the system is awoken by keyboard or mouse interaction, can you explain this further? how can it be woken by the keyboard? if the PM features are off? The Screen is still set to go off, and the Wireless goes off at the same time? is there S states in the Bios? S1 S3 S6? –  Psycogeek Jan 6 '12 at 4:55
1  
The system is setup with a screen off and no screen saver however it does not turn off the wireless with the monitor it seems to be at some large interval. There are no PM tabs on any devices. No configuration for sleep states in bios. –  JProgrammer Jan 6 '12 at 5:06
    
For me that just leaves doing one thing. 3rd party cheap trick. Find a simple no-sleep/standby type of program, one that specifically can send fake mouse and key commands to windows. Sits in the system tray has various options which include that. –  Psycogeek Jan 6 '12 at 5:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.