Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Microsoft Office 2007 running on Windows 7. Yesterday I updated Office to the latest service pack, i.e. SP3.

This morning, when opening an MS Word document (.doc format, and a document I created myself some months ago) I was greeted with a new dialog box saying:

Security Alert - Office File Validation

WARNING: Office File Validation detected a problem while trying to open this file. Opening this is probably dangerous, and may allow a malicious user to take over your computer. Contact the sender and ask them to re-save and re-send the file. For more security, verify in person or via the phone that they sent the file.

Including two links to some microsoft blabla webpage. Obviously the document is safe as I created it myself some months ago.

How to disable this irritating dialog box?

(On a sidenote, a rethorical question: Will Microsoft never learn? I consider myself a power user in Word, but I have no clue what could be wrong with my document so that it is considered dangerous. Let alone more basic users of Word. Sigh....)

share|improve this question
    
It is funny that although I am the author of the file, Microsoft still things it is potentially harmful. Nice way to piss off your customers. –  ja72 Sep 24 '12 at 18:08
    
It has to do with the tools you used to save or write the file. –  Yuhong Bao Apr 16 '13 at 6:17
    
@Yuhong: like ... hmm ... Microsoft Office 2007 ?? –  Rabarberski Apr 16 '13 at 7:21
    
That would a bug in Office 2007. –  Yuhong Bao Aug 4 '13 at 5:49
add comment

2 Answers

Looks like they increased security toward their old file formats in order to avoid vulnerabilities.

Here is some information on why it does this and how to convert the files so you won't get the error message.

Two updated error messages for the Office File Validation feature in Office 2007 SP3 now provide more detailed information and options. You will encounter these messages if you attempt to open files that are stored in Office binary file formats and if the files do not pass scanning and validation checks. Note: Office binary file formats are also known as Microsoft Office 97-2003 file formats.

...you can click the safer options link and then use one of the following options:

  1. View the file in Office 2010 by using Protected View
  2. Use the Microsoft Office Isolated Conversion Environment (MOICE) feature
  3. Open the file inside a virtual machine

Found some possible workarounds at Microsoft Technet which might be helpful. About half way down the page are some options to control how it works.

To prevent Office File Validation from validating files you must create the following registry keys & values, and assign a DWORD value of “0” for the specified application in Office 2003 or Office 2007:

Keys:

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\<version ie 11.0 or 12.0>\<app eg Word or Excel>\Security\FileValidation

Values:

(all) EnableOnLoad DWORD 0  
(Excel) PivotOptions DWORD 0  

As an example, to disable file validation for Word 2007 you need to:

add value

EnableOnLoad DWORD 0 

to key

HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\12.0\Word\Security\FileValidation
share|improve this answer
    
Could you add (quote) the relevant information to your post? That makes superuser more self-contained if the linked site(s) go down or the url becomes invalid. –  Rabarberski Jan 9 '12 at 8:31
    
I updated this for you, but there is too much information to paste into Superusers. Especially the second part. Hope that helps. –  CharlieRB Jan 9 '12 at 14:26
add comment

Close any Excel window (If open), and then perform the following steps:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate the following registry key: HKEY_CURRENT_USER\Software\Microsoft\Office\11.0 or 12.0\
  3. Click on the version number to highlight it On the menu, click Edit, New and then click Key. Type Excel, and then press ENTER.
  4. Select Excel, point to New on the Edit menu, and then click Key. Type Security, and then press ENTER.
  5. Select Security, point to New on the Edit menu, and then click Key. Type FileValidation (Note there are no spaces between the words), and then press ENTER.
  6. Select FileValidation, point to New on the Edit menu, and then click DWORD (32-bit) Value. Type EnableEnableOnLoad (With no spaces), and then press ENTER.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.