Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

For some reason whois does not seem to work on my machine:

whois heise.de
whois: connect(): Connection refused
whois google.com
whois: connect(): Connection refused
whois cia.gov
whois: connect(): Connection refused
whois wikipedia.org
whois: connect(): Connection refused

As you can see the problem persists for different TLDs so it does not seem to be just a broken whois server.

I get the same results using each /usr/bin/whois or Network Utility.

For testing I disabled Little Snitch as well as the Apple Firewall.

Other networking tools like ping, nslookup etc. work fine.

Any other ideas?

share|improve this question
    
Sounds like a network connection issue rather than a whois issue. Is your connection up and going? – user111228 Jan 6 '12 at 13:30
    
yeah everything fine icmp (ping) and dns (nslookup) as well as normal http usage seem fine – er4z0r Jan 6 '12 at 17:32
    
Did it work before? – Simone Carletti Jan 6 '12 at 23:31
    
I think it did. – er4z0r Jan 8 '12 at 12:48

Probably your ISP is firewalling outbound port 43. As a workaround, find a web-based whois service, or a proxy which will allow you to use a different, unblocked outbound port and have it rerouted to port 43 at the destination.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .