Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a flash disk possibly with bas sectors. When I try to copy data to it, it works fine until somewhere around 460Mb, and then the files start getting corrupted. The corruption happens only when I unmount and remove the drive, before unmounting, the files are fine. The linux program 'badblocks' doesn't find any bad blocks. I tried formatting it, but that didn't have any effect. I used Fat 16 and 32, and both had the same problem. Is there a way to test for bad blocks after unmounting and how do I fix them?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I guess you have synchronization problem... Before unmount do the synchronization by sync command.

If this solution will not resolve your problem, you can try hard format your USB stick by 'dd' command

sudo dd if=/dev/zero of=/dev/sd?

then create partition and do a format.

Either those solutions will not work say bye to your stick..

share|improve this answer
    
No dice. And i tried the dd a long time ago. Now to head to the local PC store. :( –  3eee3 Jan 6 '12 at 15:06
    
Did you try 'sync' command? may be you are not in trouble with bad sectors. Also you said "The linux program 'badblocks' doesn't find any bad blocks". I'm sure bad sectors are not invisible. So there were 2 options left. One is 'sync' command, the other is funeral of a stick ... –  Sencer H. Jan 6 '12 at 15:10
    
Tried that. But it always fails at the same point. What else could that be? –  3eee3 Jan 6 '12 at 15:22
    
I have no idea... :-/ –  Sencer H. Jan 6 '12 at 15:33
    
Did you try to use stick in completely different machine with windows installed? –  Sencer H. Jan 6 '12 at 15:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.