Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I work remotely and remote desktop from my WinXP machine to a Win7 box everything is fine. When I launch a virtual machine from within that Win7 box and use my mouse pointer it is invisible inside the VM. If I hover over the title bar area of the running VM my mouse pointer will turn into a hand and I can guess where my pointer is at from there but it doesnt change (into resize or a textbar for example).

share|improve this question
Do you have VMware tools installed? – Dave M Feb 2 '12 at 19:50

Easy way to solve this weird behavior with text cursors in some editors.

Go to "Control Panel" -> "Mouse Properties" -> "Pointers" tab ->

Once there select the "Windows Black(system scheme)" profile.

share|improve this answer

You could try to disable hardware acceleration in Windows 7, if it works in the VM.

Ensure also that VMware Tools for Windows Guests are installed.

share|improve this answer

I too have had this problem, the only way I could find round it was to use remote desktop to remote into the virtual machine itself directly, either that or go to and setup a free account and use that to login to the virtual machine directly. For some reason mouse pointers dont seem to roam very well between three locations.

One thing to try though, have you tried making your virtual machine full screen on the pc you are connecting to ?.

Another option is to use a lan enabled kvm switch, this is different to using remote desktop in that the signal for the mouse / keyboard is fed directly into the keyboard and mouse sockets on the pc at the other end instead of being virtualised by remote deskptop, so the mouse pointer would appear in the VM the same as it does when viewing it at the pc itself, they are not overly cheap though, although you can prob find a second hand one on ebay.,or.r_gc.r_pw.,cf.osb&fp=4c516b9b4590be31&biw=1920&bih=1109

share|improve this answer

Make sure vmware tools app is installed on the VM. If that does not help, maybe try changing your remote control app and see if that helps.

share|improve this answer

Go into the advanced system properties and ensure that the "show shadows under mouse pointer" is selected.

As strange as it seems, solved my problem.

share|improve this answer

I encountered this issue this morning on a Windows 8.1 VM. I will say this is remote access through Citrix to the Machine. To resolve it I Opened Mouse Properties > Pointer Options and selected Display pointer trails setting the distance to short to minimize the effect of the trails.

share|improve this answer
Does the mouse pointer still work if you turn trails off again? – DrZoo May 10 at 16:31
No unfortunately. I did a re-install of the system after 2 weeks and it never happened again. It was upsetting the other users of the machine. – BrianC Jun 10 at 15:34

Try disabling "Accelerate 3D graphics" option. (Virtual Machine Settings/Hardware/Display/3D Graphics).

Disabling this option should disable direct access to GPU, remote desktop emulates a graphics card instead of using real hardware. A bug on graphics drivers (real one) may be the reason for invisible mouse pointer which may not exist on emulated graphics card drivers. Updating drivers may also solve the problem.

share|improve this answer
Welcome to SuperUser. Could you elaborate on this answer? Why would this work? – mtak Jun 26 '14 at 18:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.