Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My PC has an SSD as C: and a sata drive for D:

The SSD is brand-new and so I have reinstalled Windows 7 64-bit. I have installed the latest network drivers from the motherboard manufacturer, in fact these are the same drivers I was using previously. Since the install, I've encountered a strange issue. I will start a download and it will reach the maximum speed for my connection and then freeze. The download doesn't fail, it just stops. I only see the network speed take a dive and flatline when I look at the network activity. This happens at a random time during the download. I have to restart the download process and it will then (normally) progress fine. For example, if I start a 700MB download it will stop at about 40MB. If I pause/cancel and then restart this download, it will usually continue all the way.

I thought that it might be the SSD drive, but I set the downloads to store on D: and the issue persists. It affects any large amount of network traffic - Windows updates, downloads through a browser, copying files from another computer, etc. The problem started before and after I installed updates, and I've tried turning off the firewall to no effect.

I'm not entirely sure what else I can do. I tried another reinstall, but it didn't solve the problem. I've also tried swapping the network cable.

share|improve this question
    
You have to remember that any temp downlaod data is soted on the system drive.. so on the SSD. The ssd cannot cope with the write speed, stops to catch up and then the downlaod malfucntions.. and crashed.. The joys of SSD's.. You need to setup ALL temp and CACHE to the sata drive or to RAM DRIVE! –  ppumkin Jan 6 '12 at 20:23
    
Have you tried different browsers? Like Chrome, Firefox, Opera, etc. –  kobaltz Jan 6 '12 at 20:24
add comment

migrated from serverfault.com Jan 6 '12 at 20:16

This question came from our site for professional system and network administrators.

2 Answers

It sounds less like an issue with the SSD... and more likely an issue with your ISP. I ran into similar issues and discovered it was an issue with the MTU my ISP had. I wrote a rant on the subject a while ago... but here's the general steps to diagnose/resolve:

First... look at your current MTU setting: Open a command prompt with Administrative privledges and then run the command as follows:

netsh interface ipv4 show subinterfaces

You'll see something like:

   MTU  MediaSenseState   Bytes In  Bytes Out  Interface
------  ---------------  ---------  ---------  -------------
  1500                1  8864896253  1116506364  Local Area Connection

With that knowledge you'll note that your MTU is currently set to 1500. If that's what your ISP works with... you should be able to ping sites like msn.com or google.com with a packet size of 1500 without fragmenting the packet.

ping www.google.com -f -l 1500

if you see an error message like: Packet needs to be fragmented but DF set.

You know you need to go smaller. So, subtract 8 & try again... until you find a valid MTU. Once you find the one that gives you a reply without complaining about needing to be fragmented... it's time to change your MTU. Back to the admin command prompt... and we do this: (replace 1464 with whatever you came up with)

netsh interface ipv4 set subinterface "Local Area Connection" mtu=1464 store=persistent

If you just want to test this out... without committing changes... skip the store=persistent bit... and a reboot will set it back the way it was. You can also manually set it back to whatever you started with...

I don't know if that will work for everyone... but it "worked for me" (c)

share|improve this answer
    
Good answer Wiz. –  Tim Jan 6 '12 at 20:26
add comment

Sounds familiar. Have had similar issue on downloads using both automated and manual tools after switching to a different network connection. Tweaked MTU settings until got something that worked (1392). There are obviously some tools listed below to calculate Path MTU correctly listed below. http://oreilly.com/catalog/nettroubletools/chapter/ch04.html http://www.iea-software.com/products/mtupath.cfm If you want to make certain that its not sofware related, try using a live Linux distro such as Knoppix. Is it limited to a certain time frame (to rule out ISP congestion issues)? Have you changed anything in your network lately?

Another possibility may be driver/configuration related with regards to the setup of your SSD? How can i see if my SSD needs to have TRIM run against it? What drive model/type is it?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.