Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I press the Sleep button on my keyboard, I get the Sleep I want, which allows the computer to wake up from a mouse click or key press. My wife is used to her desktop shortcut, however, and when I create one for sleep, it goes into hybrid sleep that will only be woken up by hitting the power button. In fact, any other implementation of 'sleep' puts the computer basically into hibernation, or possibly hybrid sleep.

How can I get the desktop shortcut to put the computer into a keyboard-wakeable state like the physical button? It's a Windows 7 PC.

share|improve this question
1  
You need to list the actual command the shortcut invokes. You also need to relate your existing power configuration settings. –  kreemoweet Jan 7 '12 at 19:37
    
If you're using an USB keyboard, you should make sure it is allowed to wake up the computer in Device Manager; otherwise it will be powered down during sleep. –  billc.cn Jan 7 '12 at 22:19
add comment

1 Answer

up vote 1 down vote accepted

If you don't use hibernate you could disable it all together. Find the command prompt i start menu, right click and choose "Run as administrator". At the command prompt type "powercfg.exe /hibernate off" without the quotes and close the command prompt window. Now your computer should always sleep instead of hibernate.

share|improve this answer
    
That did it, thanks! I had already set Hibernate>Never in my Power Mgmt options, so I didn't think I had to worry about that, but using the command you mentioned fixed it so the shortcut (C:\Windows\System32\rundll32.exe powrprof.dll,SetSuspendState Sleep) worked liked I wanted it to. –  Dean Jan 7 '12 at 23:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.