Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to access the help for a command by using ctrl+h in emacs, but it keeps deleting the previous character. I googled it, and apparently ctrl+h is backspace in a terminal. How do I remove this key mapping? I use regular backspace, and I want to access the emacs help using ctrl+h. I'm using cygwin and GNU Emacs 23.3.1

share|improve this question
up vote 2 down vote accepted

Cygwin's default backspace keycode was changed from ^H to ^? a couple of years ago to stop this from happening. Are you using an old Cygwin version or the no-longer-maintained rxvt, which still does use ^H by default?

share|improve this answer
    
Yea, I'm using rxvt (nice guess!). Will I have to switch to a different terminal or do you know how to change it for rxvt? – gsingh2011 Jan 9 '12 at 5:34
    
Give mintty a try, which has recently become Cygwin's default terminal. Like rxvt, it doesn't require an X server, but it provides xterm-compatible terminal emulation, Unicode support, and a more Windows-native UI with an options dialog. With rxvt, the command line option -backspacekey '^?' should do the trick. – ak2 Jan 9 '12 at 9:02
    
I think I tried this when you responded and it didn't work (not 100% sure that I did), but I've switched to mintty since then so I'll accept your answer. – gsingh2011 Mar 14 '12 at 1:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .