Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have set up my Gmail account with Outlook 2010 SP1 using IMAP. One problem is bugging me like anything here is the sync problem. When I hit "Mark All as Read" in outlook for gmail account, outlook becomes non-responsive for several minutes. On the other hand Windows Live Mail is setup with same gmail account in same machine, but it is quite fast in this operation.

I let outlook automatically set up my gmail account, but I don't know what's going wrong here.

Following is my system spec

Win7 ultimate 32 sp1
Outlook 2010 sp1
MS Security essential
Comodo firewall [IMAP ports are open, as WLM is working fine]

Can anybody please suggest me some workaround here to speed outlook up? I have searched a lot in Google and MS Office help site, but nothing is of good help.

share|improve this question
    
How many messages are you syncing to your Outlook? Every single message from Gmail, or only the last couple of days or so? –  iglvzx Jan 7 '12 at 20:33
    
I have over 2000 mails in Gmail, but all them except the recent 20 mails are all READ. I am trying to mark those 20 messages as READ from outlook. Same operation is happening in WLM in just moments, but outlook seems to take forever!!! –  Anindya Chatterjee Jan 7 '12 at 20:40
    
I usually use this option for Spam and Trash folders-"Download holders only" and for Inbox and Drafts-"Download complete item including attachments".This prevents Outlook from downloading mails and attachments that are marked as Spam by Gmail. –  ahmed Jan 7 '12 at 20:53
1  
I too had the same problem but this helped me out. –  ahmed Jan 7 '12 at 21:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.