Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How are you supposed to use a home network when using OpenDNS? If you set it as your DNS on the router it hijacks even Windows file sharing traffic so you can see computers on the network but when you click on them it won't go. You can only access them by IP address, but this isn't acceptable. If you ping the computer name you get COMPUTERNAME...ISPSERVER.com or .net or whatever. How do people deal with this?

share|improve this question
3  
You have me completely at a loss on this one. I have used opendns on 3 or 4 networks over the last 3+ years and don't see any difference in anything except the internet sites I want blocked are blocked. I can go in and switch my router from "Obtain DNS information automatically." to "Manually configure your DNS information" using opendns and back again (and sometimes do) and no one on the networks notices anything. Here it is completely transparent and each network has 5-15 computers with multiple operating systems (Apple, Linux, and Microsoft). –  Dennis Jan 8 '12 at 3:24
    
Well I still have the problem after getting a new, totally different router, and it affects every computer on the network (Windows Vista, XP, 7 and a Mac), so I assumed this is a universal issue. I don't have any weird network setup. Just plugged it in and added the OpenDNS IPs. –  Moss Jan 11 '12 at 4:50
add comment

2 Answers

Please ensure you are using the double slashes before the computer name in windows explorer address bar (\computername\share). If you do not, explorer will think that you want to go to an internet site. This is the default behavior of explorer.

Also, it sounds like you may have a 'search domain' set up. This will attempt to search that domain for computers (e.g. computername.opendns.org).

If you are trying to use your own internal DNS servers, you should have your router use the internal servers and those DNS servers should be configured to forward unanswered requests to the OpenDNS servers.

The only other configuration is to use the windows host file to define the ip address of the computers on your network. The issue with this is that the computers need static IPs.

If you just set this up, open a command prompt as and admin user and issue a ipconfig /flushdns

That will clear the local cache and ensure you're getting the right result from the DNS.

share|improve this answer
    
I use the double slashes. I don't know anything about search domains so I don't think I have one. I just have a standard default home network. I'd rather not have to use a host file. I would rather just have my network work like it is supposed to. –  Moss Jan 11 '12 at 4:54
    
It's a pretty curious issue. Are all your clients using DHCP from the router? Are your computers part of a domain? –  skub Jan 14 '12 at 5:25
    
Yes, they are getting DHCP from the router and no, they are not part of a domain. –  Moss Jan 26 '12 at 3:49
add comment

The most likely cause of this is that you have no DNS at all for your internal network, so you're relying on the old NetBIOS/WINS lookup method. Windows only uses this method if the name you enter does not resolve in DNS.

Because OpenDNS has "wildcard" DNS support (i.e. when you type a nonexistent address, you get redirected to an OpenDNS search page), now all possible addresses resolve in OpenDNS's DNS. This means that Windows won't fall back to the old NetBIOS/WINS method and you'll end up trying to connect to one of OpenDNS's servers, rather than your internal network.

The solution to this is to get DNS working on your internal network. Firstly, make sure you're using your router as a DNS forwarder and not going straight to OpenDNS from your PCs (i.e. configure OpenDNS on your router and leave DNS automatic on your PCs). Second, make sure your router supports resolving DNS for the internal network and this is enabled. Thirdly, ensure that all PCs have valid hostnames set (Windows is more relaxed than DNS about what you can use in hostnames, use only a-z 0-9 and '-').

Hopefully this should put you on the right track...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.