Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

As I need to use dnsmasq to route all requests on *.local to my local machine (and use there an IPv6 addresses), i set up the dnsmasq like this:

/etc/dnsmasq.d/my-local.conf

address=/local/::1
listen-address=::1

/etc/resolv.conf

nameserver ::1
nameserver 127.0.0.1
# Generated by NetworkManager
nameserver 192.168.43.1

But dig anything.local returns no answer. What did I set wrong?

radek@me:/$ dig anything.local

; <<>> DiG 9.8.1 <<>> anything.local
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30189
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;anything.local.            IN  A

;; Query time: 0 msec
;; SERVER: ::1#53(::1)
;; WHEN: Sun Jan  8 09:39:10 2012
;; MSG SIZE  rcvd: 32

If change my-local.conf like this:

address=/local/127.0.0.1
listen-address=127.0.0.1

i get this:

radek@me:/$ dig anything.local

; <<>> DiG 9.8.1 <<>> anything.local
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 13675
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;anything.local.            IN  A

;; ANSWER SECTION:
anything.local.     0   IN  A   127.0.0.1

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Sun Jan  8 09:40:47 2012
;; MSG SIZE  rcvd: 48

which means that troubles could be caused by IPv6 addresses.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.