Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run Fluenz on my computer and it's a .osx file. When I try to open it, it opens in Textmate. Kind of odd. Does anyone know how to restore its original default program? I think that I might have changed all .osx files to open in Textmate some time in the past for a programming project, but I don't know what the original was.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

There is no real default program, as the file type is apparently not known by OS X (at least on my system). It depends on the applications you installed on your system.


You can always right-click and select Open With… to see which applications claim support the file type. If the desired program is in the list, you can Get Info the file, and then change the program to use for opening all files of this kind. This setting is in the Open with section by selecting it and then pressing Change All….

enter image description here


To remove the custom association with TextMate, remove the matching entry from ~/Library/Preferences/com.apple.LaunchServices.plist in the LSHandlers section and reset the Launch Services database by running the following in Terminal:

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r domain local -r domain system -r domain user

share|improve this answer
    
The last step might be overkill. Edit the plist and restart your system to see what happens before resetting Launch Services. –  Daniel Beck Jan 8 '12 at 21:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.