Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After installing VirtualBox 4.1.8r75467 on a Windows 7 64 bit host, the bridge adapter doesn't appear to have been installed. It doesn't show in device manager, and in VB, changing Settings > Network > Attached To to Bridged Adaptor shows only Not Selected in the Name dropdown. No error message during install, and yes I did confirm during the installation.

Things I've tried:

  • Using installer to repair the install
  • Complete uninstall and reinstall
  • Reinstall in safe mode
  • Reinstall with UAC and anti-virus (Kaspersky) disabled
  • As recommended in an older issue here, tried to delete this file, but was denied access, even in safe mode: %SystemRoot%\System32\DriverStore\INFCACHE.1

This is a blocking issue, and I'm out of things to try. Any suggestions would be very much appreciated.

share|improve this question

migrated from Jan 8 '12 at 19:27

This question came from our site for system and network administrators.

This response here about the MaxNumFilters registry value fixed the problem for me:

Resolved my issue not sure if it resolves the issue for others, my Windows 7 had run out of network filters, changing the registry entry for network filers form 8 to 14 allowed the bridging to the adapters to show


I saw a lot of entries in device manager when I showed the hidden ones, so I set the max limit to 24, and the install appears to have worked.

share|improve this answer

I was experiencing similar trouble, and while some of the ideas here helped ultimately the issue was VirtualBox getting hung up on my existing bridged network adapter. You don't mention details about your adapter configuration.

This is what worked for me -- YMMV.

  1. Before each step, disable virus protection. After each step reboot.
  2. Increase the number of net filters: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters I bumped this number up to 32.
  3. In Device Manager, select 'View Hidden Adapters', and delete all of the "Unknown device" network adapters
  4. Uninstall VB
  5. In Device Manager, delete any remaining (hidden) network adapters with the word "VirtualBox" in their title
  6. Critical step: In Control Panel/Network and Internet/Network Connections right-click on Network Bridge and open properties. Under 'Adapters' de-select everything. Apply, OK, close
  7. Install VB (leave the default selection, which is everything)
share|improve this answer
You don't need to set MaxNumFilters in Windows 8, as the limit is now automatic. I think the most important step above is to remove your external interface from any Microsoft Bridge that it might be part of. Otherwise it won't even be listed as an option for a Bridged Adaptor in VirtualBox. – qris May 28 '15 at 16:10
Do you mind being more specific besides "Network Bridge" on the 6th step. I can't seem to to follow your steps. – William Nov 11 '15 at 19:17

Raising limit for network filters also helped with Symantec Network Threat Protection (in a perfectly working SEP, firewall module was disabled and not present in the interface). Hope this helps, I was searching for solution for a few months and found nothing. VirtualBox bridge adapters also work correctly now.

I think such problems occur if you had installed several different VPNs or similar software on one PC.

share|improve this answer

File a bug report at Oracle. Wait for the next version.

share|improve this answer

I don't think the bridged adapter is supposed to show up in the device manager, just the VirtualBox Host-Only Ethernet Adapter - I am guessing that doesn't show up either?

I would suggest trying a couple of things:

First, did you verify the MD5SUM/SHA256 hash of your download with the versions stored on the download page:

Second, can you use System Restore to go back to a known good state before trying to install VirtualBox?

Third, use the Certificates MMC snap-in to look in both your user store and computer stores for any certificates from Oracle or Sun - and delete them. This should ensure that you get a prompt when installing asking if you want to trust the device/vendor. Of course you want to trust them to enable all of VirtualBox's features.

share|improve this answer
Thanks for your ideas. - MD5 check was worthwhile, but it matches. - Re known-good state, other than this, my system is healthy, AFAIK, developing on it. Earlier version of VB I had used only NAT, so bridge adapter state is unknown. - Removed the Oracle cert, and did get a further prompt, but no change; empty Name dropdown when set to Bridged Adapter. I could report it, but it's hard to believe this happens to everyone who installs this version of VB on Win7/64. Wish I knew what's "special" about my system, or how to work around it. – enigment Jan 8 '12 at 3:37
Actually, it appears that at least some people have had this problem, over a long period of time, across multiple VB versions. See here: Looking into the workarounds suggested, some of which I've already tried, some not. – enigment Jan 8 '12 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .