Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm doing my head in here, was hoping someone could help me.

I'm trying to setup my web server at home. It has a static ip of 192.168.1.8. I've setup IIS on Windows 7 and am hosting my site on port 8888. I can browse it fine using 192.168.1.8:8888.

I've setup No-ip to hit my router @ 121.45.178.:8888 ( to block my numbers!). And I've setup port forward on the router (NetComm)

Server name |Ext port start-end |Int port Start-End |Server
IP TEST     |8888-8888          |8888-8888          |192.168.1.8 pppoe_0_8_35

When I go to http://www.canyouseeme.org/ it works fine and I get the "Your ISP is not blocking port 8888." However, I cannot browse the site. Using fiddler I've found I got:

No connection could be made because the target machine actively refused it

I have disabled all firewalls. I even uninstalled them to make 100% sure. This is doing my nut in. I know there is a connection because, when I stop the web site in IIS, I get a "connection refused" on the canyouseeme.org. So there is a connection; I'm just not sure why I cant browse the site from an external network.


It was working all the time. the problem is you cant browse it when connected to your own wireless network. so if you browse the web server from another computer on the network, it didnt work properly.

share|improve this question
    
It might help if you explained what you changed from before (when it was only working from outside your LAN), and what your browser shows when you try to browse the site using your external IP or the No-IP domain name. If IIS is only hosting one site, and is bound to port 8888 on all IPs (both your LAN and External IP), and you have port forwarding set up correctly (using a static IP), then it should work. –  Lèse majesté May 6 '12 at 5:21
add comment

migrated from serverfault.com Jan 8 '12 at 20:34

This question came from our site for professional system and network administrators.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.