Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a webserver running on a virtual platform (VBox). Have set the VBox adapter to bridged mode. I am able to access the webpage from my host machine. I have also configured dynamic DNS (No-IP) on my guest (Ubuntu Server). Port-forwarded port 80 on my router as needed for accessing the server.

Basically, I can access the internet from both the guest and the host machines and can even successfully load the webpage from my host machine when the server is up and running. However, whenever I try connecting through my no-ip URL I am faced with the login page of my router instead of the webpage I should be seeing. Any idea what I'm doing wrong? Do I have to configure the No-IP settings on my gateway router as well for it to connect successfully to my webserver located on the internal/virtual network?

Any help/suggestions would be appreciated. Been trying this for over a week now. Its really doing my head in =/

PS: Also all machines are on the same subnet, hence connectivity in a a way doesn't seem to be the issue, i.e. all machines internally seem to connect fine. What I wonder is why the No-IP url connects to 192.168.1.1 (my gateway) rather than 192.168.1.10 (my webserver/VBox machine).

Would this mean I have to configure No-IP on my gateway such that any incoming request to my external-IP/gateway gets forwarded to the VBox?

share|improve this question
    
Have you tried connecting from an outside machine? My guess is that because you are using the ip of the router from an internal address, the router is giving you its internal page rather than the port forward. If the request came from external it may work okay. –  Paperlantern Jan 9 '12 at 2:04
    
I tried that before and just tried it again as well. No luck. Page doesn't load. –  Cygnus Rift Jan 9 '12 at 2:25
    
Without seeing the config of the router to make sure the forward is set up right it will be difficult to determine the problem. If the forward is set up right you should at least see it from external. Chances are something is wrong there –  Paperlantern Jan 9 '12 at 3:15
    
Just curious, what is the model/brand of your router? –  skub Jan 9 '12 at 5:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.