Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Ok, so I have an Apple MacBook Pro MD313LL/A powered by OSX Lion.

What I am trying to do is to get Backtrack to run natively on it.

Since bootcamp only supports windows dualbooting, I found a workaround by using something called rEFIt. I enabled the rEFIt bootloader and used a GParted live cd to create an ext3 partition which I was eventually going to place the backtrack instance on.

The problem I encounter now is that when I try to use any kind of live cd (by pressing the "c" key while rebooting) the live cd fails. It gets stuck at the point where the filesystem has to be transfered into the RAM (initramfs).

I get prompted with the message: didn't find a medium with live content (or something like that...). This is strange because I was trying to use the same backtrack live cd which was fully working a few steps ago. I also tried inserting the live cd in some other PCs/laptops which worked correctly. I also tried burning new live cds of backtrack (different architecture this time) and Ubuntu.

Any ideas on what I could have done wrong or why this is happening ?

share|improve this question
add comment

2 Answers

up vote 0 down vote accepted

While I'm not 100% sure why it fails there is a workaround for this. In addition to burning the ISO to a DVD, burn it to a USB drive as well using dd, this will completely wipe out anything on the USB drive, so back up first!!

Determine your disk number by issuing this command:

diskutil list 

Insert the USB drive and run the command again. Identify what disk number your USB drive receives.

Now run:

sudo dd if=/path/to/iso of=/dev/diskX bs=1m

Where X is the number identified in the first step. If it gives you an error about 1m try using 1M instead. this will take a while ~10 minutes.

Now boot up as you described in your question (holding the 'c' key) but be sure to have the newly burned USB drive connected. Now it should boot up properly.

share|improve this answer
    
Hmm interesting info I'll defenitely try it out as soon as i get some spare time. Tnx alot for the answer. –  Calin Paul Alexandru Feb 21 '12 at 12:27
add comment

I have the same problem using the latest ubuntu 11.10 cd. While in the initramfs environment I was able to find out if my dvd-drive was even detected, if so it would be listed as /dev/sdb. There was however no /dev/sdb so for some reason the drive was not detected and thus the initramfs environment couldn't load the files for the second stage of the bootprocess.

in short, there is a version of ubuntu that should fix this problem:

[ ] ubuntu-11.10-alternate-amd64+mac.iso 11-Oct-2011 12:46 673M Alternate install CD for 64-bit Mac (AMD64) computers (standard download) [ ] ubuntu-11.10-alternate-amd64+mac.iso.torrent 13-Oct-2011 09:53 27K Alternate install CD for 64-bit Mac (AMD64) computers (BitTorrent download)

at http://cdimage.ubuntu.com/releases/11.10/release/

Further: i have read, (can not confirm) that the 32 bit iso does not have this problem

share|improve this answer
    
Hmm tried the 64 bit mac release, still having the same problem –  peterrus Jan 26 '12 at 13:25
    
goes for 32 bit aswell. –  Calin Paul Alexandru Jan 27 '12 at 8:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.