Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

After choosing an option at the installation menu, the screen turns lack. It doesn't matter if I choose "Install" "Graphic install" or "Expert install".

I,m using a Macbook5,2 and I am trying to install the internet installation of Debian 6.03 from a CD for AMD64.

I used the tutorial here http://wiki.debian.org/MacBook and used refit to boot to the CD.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

From the article you linked, there seems to be a known issue with the Linux Kernel (bug 13170) that it only boots on a MacBook 5,2 with (one of) certain boot parameters set:

  • acpi=off
  • nosmp
  • maxcpus=1

Obviously, use of these parameters "works" by disabling or circumventing some aspects of your hardware configuration. You should give the bug report (and the discussion that follows) a look to to make sure you understand which one is going to best suit your needs. One of the folks out there claims to have gotten his MacBook 5,2 to work without those boot parameters, but indicates that his CPUs then only work at their minimum speed.

That's the thing about Linux. It's cool because it's free, open source and customizable. But install/configuration can sometimes be challenging.

Anyway, give the bug report a read. It should give you some things to try.

share|improve this answer
    
How do I pass those arguments to the installation CD? –  Tyilo Jan 9 '12 at 14:59
    
You should be able to get to the boot prompt by selecting the "Help" option from the install CD menu. Then you'd do an "install acpi=off", or whatever. –  BryceAtNetwork23 Jan 9 '12 at 15:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.