Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Asus EEE PC 701 4G that won't go past the bios screen. The keyboard isn't working either so I can't access the bios. I've tried a live OS on USB but it fails to load. It gets stuck at this screen: eee pc boot screen

Any thoughts on why this is happening? And how to fix it?

EDIT
Unfortunately theres not light for the caps lock so I can't test this, but I have plugged in an external keyboard and still nothing. I have also tried to reinstall the BIOS, but to no avail.

share|improve this question
    
Have you upgraded the RAM or the BIOS lately? –  Herman Torjussen Jan 9 '12 at 17:33
    
Yes to the ram. Although I was given it in this condition, I upgraded the ram as I thought it might have been faulty, and I've been pressing the reset buttons and things. –  Dean Jan 9 '12 at 17:38
    
@hesse ^ sorry forgot to mention you in the comment. –  Dean Jan 9 '12 at 19:12
    
Check to see if the capslock light still toggles when it sticks. That will tell you if the computer is stuck or completely frozen –  ChargerIIC Jan 9 '12 at 20:33
    
@ChargerIIC Edited my question. –  Dean Jan 10 '12 at 13:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.