Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a tomato router upstairs (192.168.1.1 connected to modem for internet) and a dd-wrt router (192.168.1.2 connected to .1) downstairs. I have cat-5 running between the two routers. I would like my dd-wrt router to act like a switch (and accept more devices via ethernet) and also extend my wireless range. I am confused on the best way to do this. I don't think I want a bridge or an access point because the routers are connected via LAN, and all tutorials seem to be about extending wireless without a LAN connection. I also don't want 2 different SSIDs. I want 2 routers acting as a team on one network.

My current solution is just to have both routers using the same wireless settings (matching SSIDs) but I don't notice any wireless boost with this method.

Can anyone walk me through this setup?

Thanks a bunch

share|improve this question
add comment

2 Answers 2

With your current setup, the upstairs LAN, upstairs WIFI and downstair LAN all form the same layer 2/3 network. Ie, all the devices should be within the 192.168.1.0/24 network.

Provided you are only running DHCP on the upstairs router, you should be able to achieve "accepting more devices via ethernet" right now without doing anything. Ie, plug something into one of the other LAN ports on the dd-wrt router (this assumes that you have connected the two routers via their LAN ports, rather than using the WAN port on the dd-wrt router - if you haven't then this is what you should do), and it should pick up an IP address from the upstairs DHCP server and connect to the internet and all the other devices on the network.

Equally, the default setup for wifi on a router is for it to be bridged to the LAN ports, so again, just enabling wifi on the dd-wrt router should be enough to it to work, and yes it should be configured in AP mode.

You can leave the SSID the same as the upstairs router, but it is important that you choose a different channel. Choosing betwen 1,6 and 11 is best (for 802.11g) as these have minimal overlap. For 802.11n, you can usually leave channel selection to Auto and it will work out the best channel selection. If you are using 802.11n in a "busy" area with lots of other APs, then don't enable 40Mhz bandwidth, leave it at 20Mhz. This will reduce throughput, but also reduce interference. If you have 5Ghz radios, then you can often leave it at 40Mhz as these are less common.

share|improve this answer
    
I have the ethernet all setup, it's the wireless that has issues. So I dont want to do WDS to connect the two, right? You are saying just set the dd-wrt as an access point and match the settings? This sounds similar to what I have now, except I dont see any wireless performance boost. –  FatThumbs Jan 10 '12 at 0:28
    
@FatThumbs sounds like you have it set up correctly. How about changing the downstairs SSID and forcing your connection through it to see if it works properly, and if you actually get any better wifi (as a test) –  Paul Jan 10 '12 at 0:47
add comment

What you need to do on the second AP is disable the wan connection and the dhcp server. You also need to change the default LAN IP to a one which you are not currently using on your network, and which is also outside of the DHCP range on your first AP. Next, in the VLANs tab, switch the WAN port from vlan1 to vlan0 (assuming you have the default settings). This should bridge all the ports on the router. Then you can plug the ethernet cable from the first AP into any port you wish. This is the simplest possible way to do this.

One more thing. Don't expect roaming to work seamlessly. It is pretty much guaranteed that you will lose some packets while switching from one AP to another.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.