Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running Firefox 9.0.1+build1-0ubuntu0.11.04.1 (that's on Linux Mint).

One of the tabs has a site loaded which crashes Firefox each time it loads.

Therefore, I can't close the tab quickly enough after starting Firefox to stop that site loading.

How can I make Firefox "forget" its current session?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You can also start Firefox in Safe Mode by quitting Firefox and then going to your Terminal and running:
firefox -safe-mode

Source: How to start Firefox in Safe Mode

A bit late but I confirm it's normal behavior, safe mode only loads the strict minimum from your profile in order to prevent cases like these.

share|improve this answer
    
From safe mode, can I get Firefox to forget the tabs open in "normal" mode? –  eoinoc Jan 10 '12 at 11:24
    
Tools/Options/General/StartUp and set "When Firefox starts" to "Show a blank page" –  stuartd Jan 10 '12 at 11:51
    
Fixed by just entering safe mode: When I started safe mode, it gave me the screen "Well that's embarrassing". I was able to choose "Start new session". Firefox in normal mode now starts with my normal homepage only, which was the setting already... –  eoinoc Jan 10 '12 at 12:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.