Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Problem:

Today I attempted to open a document with libreoffice. I got the error "could not open application. There is a general error in your central configuration file."
Naturally I opened up my configuration editor and started looking for keys related to libreoffice. Couldn't find any.
Tried reinstalling. Didn't work.
Tried uninstalling and installing open office. Didn't work.

System:
Ubuntu 11.10 GNOME3

Any ideas?

Update:
I get the following when attempting to run from terminal:
[Java framework] Error in function createSettingsDocument (elements.cxx). javaldx failed! Warning: failed to read path from javaldx terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

share|improve this question
    
Did you purge openoffice before re-installing? Did you try to rename the old settings directory ~/.openoffice.org/? – tohuwawohu Jan 10 '12 at 16:56
    
Worked. If you make that an answer I'll accept it. Thanks! – Yitzchak Jan 10 '12 at 22:58
up vote 1 down vote accepted

The error appearing in the terminal (javaldx failed) points to a problem regarding the user config directory. I assume that deinstalling OpenOffice.org doesn't modify the user's config (even purging - apt-get purge ... - leaves those contents untouched), so removing or (better!) renaming the user config directory may help. It's placed in ~/.openoffice.org/ since OpenOffice.org 3.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .