Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Last week I started my Windows 7 laptop in safe-mode, since then, even if it boots normally, the aero effects are disabled. It comes back after running the aero troubleshooter, the diagnostic message displayed is

  • Desktop Window Manager is disabled Detected
  • The current theme doesn't support Aero Fixed

How can I make the aero work without running the troubleshooter everytime I login?

share|improve this question
add comment

1 Answer

Force Enable Aero in Windows 7:

  1. Click on Start and type regedit at run

  2. Navigate to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\DWM
    
  3. In the right details pane, create following Three DWORD (32-bit value) entry

    • UseMachineCheck, and set its value to 0.
    • Blur, and set its value to 0.
    • Animations, and set its value to 0.
  4. Close Regedit

  5. Click on Start and type CMD with administrative Priviliges

  6. Now type the following commands:

    Net Stop uxsms  
    Net Start uxsms
    

    The above commands will stop and start the Desktop Window Manager Session Manager.

  7. Now you can turn on Aero by right clicking on desktop-> Personalize -> Select Windows Colors

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.