Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to create a ERD using VISIO Professional 2010 (full install) but I am having problems.

  1. I can't open the table properties windows at the bottom of the screen when I double click on a table, and I can't right-click on the table and choose properties because the choice is not there...

  2. The Database tab is missing from the ribbon on top.

What can cause this? Here is what I already tried: File/Options/Trust Center/ Trust Center Settings.../Add-ins/Disable all Application Add-ins is UNCHECKED

share|improve this question
up vote 1 down vote accepted

For #2...I managed to find this thread from the Microsoft TechNet forums that discusses this: Visio 2010 Professional No Database Tab

From the post:

If you still don't see the Database tab on the ribbon in a new Database Model Diagram go to File/Options/Trust Center/ Trust Center Settings.../Add-ins/Disable all Application Add-ins (may impair functionality) is unchecked.

And I apologize for my first answer. Somehow I read "Visual Studio" instead of Visio.

share|improve this answer
I already tried that, it's already unchecked. – JFB Jan 10 '12 at 21:42
Which edition of Visio 2010 do you have? There's a related post that explains why this is important:… ...unless that's not what you're looking for. – Aaron Jan 10 '12 at 21:44
I am running Visio Professional 2010 version 14.0.4760.1 (32-bits) – JFB Jan 11 '12 at 14:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.