Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a home server running Ubuntu 11.10.
It is currently configured to have a static IP address via my router.
I also use a Dynamic DNS service built into the router to update my domain name to point to that statically assigned domain name.

I can access the server via SSH using either the internal IP address or the domain name.

However, when I tried to access it via a browser, it says it cannot connect. I even tried to read it from the local computer using wget localhost and that says connection refused.

I then used sudo netstat -lep --tcp and there was no apache2 in the output. I don't know what its doing now.

I have apache2 installed, have restarted it, rebooted my computer and even reinstalled it.

Checking the logs, I see the following error:

/usr/sbin/apache2: symbol lookup error: /usr/lib/php5/20090626+lfs/ undefined symbol: php_pdo_declare_long_constant

share|improve this question

migrated from Jan 10 '12 at 22:15

This question came from our site for system and network administrators.

Have you started Apache? Did you even install Apache? – Ben Pilbrow Jan 9 '12 at 23:47
Yes I have. I updated the question. – chustar Jan 9 '12 at 23:48
Sounds like Apache isn't running - try to start Apache with service apache2 start, and see if there's anything interesting in the error log in /var/log/apache2/? – Shane Madden Jan 9 '12 at 23:48
@ShaneMadden, thanks. I updated the question with the results – chustar Jan 10 '12 at 0:01
up vote 1 down vote accepted

fast way to test if apache is running
ps -C httpd
if you have nmap installed see if the port is open
nmap -p 80 if this returns 80/tcp open httpd the problem is in your routing

see , for this error looks like a version mismatch apache php-pdo module

share|improve this answer
Thanks. I removed the pecl installed pdo library. I don't know if I'll need it anytime soon – chustar Jan 10 '12 at 0:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.