Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am running windows 2003. We have active directory in my organization. I have a user -- for example -- called Bob Smith (e-mail is bsmith@organization.com, again, made up).

Just for the record, Windows permissions are somehwat voodoo for me (if you happen to include a good primer or suggest a good book I will be very happy).

I have this directory layout. \websrv\Inetworkpublish$\www-intra\ac\dir\Finance-Dashboard

The directory "ac" I have shared by going to properties and turning it into a share. The directory "dir" is just a directory. I have also made "Finance-Dashboard" into a share. I gave the above path to the user and told him to put it in Start -> Run (he has Windows 7) and he got this error:

Cannot find file "\\websrv\Inetworkpublish$\www-intra\ac\dir\Finance-Dashboard".  Verify the path or Internet address is correct.

Ok, I simply do not understand, but why is it not working for him? I am genuinely lost here.

I suppose it would not hurt to give you the permissions that I gave this guy :)

+------------------------------+--------------+----------+----------+
|                              |      Hex     |Folder and|          |
|                              |Representation|subfolders|Files only|
+------------------------------+--------------+----------+----------+
|Full Control                  |       F      |          |          |
+------------------------------+--------------+----------+----------+
|Traverse Folder / Execute File|       6      |     x    |          |
+------------------------------+--------------+----------+----------+
|List Folder / Read Data       |       1      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Read Attributes               |       8      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Read Extended Attributes      |       4      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Create Files / Write Data     |       2      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Create Folders / Append Data  |       3      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Write Attributes              |       9      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Write Extended Attributes     |       5      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Delete Subfolders and Files   |       7      |          |          |
+------------------------------+--------------+----------+----------+
|Delete                        |       A      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Read Permissions              |       B      |     x    |     x    |
+------------------------------+--------------+----------+----------+
|Change Permissions            |       C      |          |          |
+------------------------------+--------------+----------+----------+
|Take Ownership                |       D      |          |          |
+------------------------------+--------------+----------+----------+
share|improve this question
    
Quick question you don't have anything that might deny access for that user. Because deny always overrides allow? – nhutto Jan 11 '12 at 15:51
    
If it is set somewhere in a higher directory, then I have no idea since it is not inherited down in the lower directories. I have given access to other people in the past (not directly, but so that the path can be used by an application) and they were able to access the directory. – gp443 Jan 11 '12 at 17:06
    
just wanted to check for trouble shooting purposes. I figured that was not the case but if it was then it could be an easy solution. – nhutto Jan 11 '12 at 17:10

instead of using the hostname of \\websrv\ replace it with the ip like \\192.168.1.2\ worth a shot. Maybe he can't reach the server at all? Side note I just found out in windows $ is alright in the folder structure from this post. lol

share|improve this answer
    
The $ has something to do with indicating that this is a share. I do not know why, but it does (not saying that you can have directories called $uper_$ecret_$tuff, you might, I do not know). I did most of my permissions as chmod -R 0664 and the like on a Linux machine for the past 6 years, so this is very new to me :) – gp443 Jan 10 '12 at 23:14
    
But I think that this is not a DNS issue, the name gets resolved correctly, he is merely getting an error message stating that he does not have access to the file. This is not a networking issue, I have not had one before and the networking department did not get any complaints from other users. – gp443 Jan 10 '12 at 23:16
    
$ simply means a hidden share -- Windows Explorer and net view do not show shares ending with a $ when browsing the network. (They are still listed at protocol level, though) This function only works for shares; if you name a folder secret$ there will be nothing special about it. – grawity Jan 10 '12 at 23:56
    
@gp443: The message does not mention access; it says "path not found", which might mean an incorrect server name, share name, or path. – grawity Jan 11 '12 at 0:11

Try the UNC path \websrv\Finance-Dashboard. Any change? Can the user access any share on that system? Does he see anything if he uses path \webserv?

If there s a DNS issue, the suggestion from @nhutto will point that out.

share|improve this answer
    
I sent that string to him to try it out. I will keep you posted if this works or not. – gp443 Jan 10 '12 at 23:12

SMB paths start at the shared directory, not at the filesystem root. If the computer is named websrv and you shared C:\Inetworkpublish$\www-intra\ac, the path will be \\websrv\ac.

C:\Inetworkpublish$\www-intra\ac\dir\Finance-Dashboard\
                     \\websrv\ac\dir\Finance-Dashboard\

If you create a second share below the first one, it will again start at the directory you shared, not at C:\ or anything:

C:\Inetworkpublish$\www-intra\ac\dir\Finance-Dashboard\
                     \\websrv\ac\dir\Finance-Dashboard\
                            \\websrv\Finance-Dashboard\

(The share name and the directory name are by default identical, but they do not have to be. You can always rename shares.)


When used as the last character of a share name, $ makes it hidden – not displayed by Explorer or net view. For example, \\server\C$ will be hidden (but \\server\foo$bar will remain visible). This is purely a convenience feature, though; such shares are still listed at protocol level.

The $ character has no special meaning in file or folder names.

share|improve this answer

In Windows XP, I ran into such similar issue. The reason is TCP/IP NetBIOS Helper in Services.msc needs to select Startup Type of Automatic instead of Manual. It works after this setting change

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .