Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Previously I've used an SSH tunnel:

ssh -D 1234 user@remoteHost

As a system wide proxy in OS X by going to System Preferences -> Network -> Advanced -> Proxies -> Tick SOCKS Proxy and enter localhost 1234 -> Ok -> Apply

SOCKS Proxy Setup

But it seems this no-longer works for me, the terminal appears to be completely ignoring the network config to use the proxy but other programs are using it correctly.

Can anyone offer any suggestions or a solution?

Thanks.

share|improve this question

migrated from stackoverflow.com Jan 11 '12 at 9:57

This question came from our site for professional and enthusiast programmers.

    
github.com/apenwarr/sshuttle –  user7541 Jan 10 '12 at 20:21
add comment

1 Answer

up vote 0 down vote accepted

Programs have to be specifically written to check the OS X network settings to get the proxy settings; most terminal command are standard unix (/posix) programs that haven't been modified to know anything about the way OS X manages proxies. However, it depends on the particular program. Some have command-line options that let you specify a proxy, like this:

curl --socks5 localhost:1234 "http://www.apple.com"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.