Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a local Apache server for testing purposes, my setup worked just fine until I upgraded to Apache 2.2 and now it refuses to start. I use virtual hosts like this:

<VirtualHost *:80>
  ServerName local.test
  DocumentRoot "E:/site"
</VirtualHost>

where E: is a DriveCrypt-encrypted partition. (It's fully accessible from file explorer and no other software refuses reading from or writing to it.)

Trying to start Apache will show this message in the Windows event log:

The Apache service named  reported the following error:
>>> DocumentRoot must be a directory 

It only seems to accept c:\ paths. Having sections to set permissions isn't allowed either:

The Apache service named  reported the following error:
>>> Syntax error on line 197 of C:/prog/Apache/conf/httpd.conf:     .
The Apache service named  reported the following error:
>>> <Directory "d:/"> path is invalid.     .

How can I fix this?

PS: I'm not allowed to tag this with "drivecrypt" because I'm a new user on superuser - perhaps somebody else can?

share|improve this question
    
Do you start Apache with your user credentials or as a service using a different service account? –  Robert Jan 11 '12 at 19:00
    
I've tried both, neither works (assuming it's sufficient to edit properties of the service in the windows services overview and try to start it again without an actual OS restart) –  hallvors Jan 11 '12 at 21:10
    
I'm pretty sure I don't tick the box for mounting the DriveCrypt disk for current user only either. Will double-check that when it's convenient to dismount.. –  hallvors Jan 11 '12 at 21:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.