Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a program and want to either bring its Window to the front or reopen it after it is minimised.

It is on the taskbar and hovering over it shows the preview of the window. However clicking on it does not make it reopen and become visible.

This happens with Notepad++ and Beyond Compare - both of which have tabbed panes.

Any advice on how to force the Window to reopen?

share|improve this question
    
Another tip: If I wait a moment the program will open eventually. –  therobyouknow Oct 29 '12 at 14:12

4 Answers 4

up vote 5 down vote accepted

Try hold Windows Key + Shift then press the Left Arrowkey 2 or 3 times. If that doesn't work try again with the Right Arrowkey instead.

share|improve this answer
    
+1 @Mark Price - thanks I will check that out next time. –  therobyouknow Jan 11 '12 at 15:19
1  
This often happens when the window somehow ends up off screen in its restored state. Mark's answer will usually work, or you can right click on the preview and select "Maximize". –  Eclipse Jan 11 '12 at 16:29
1  
Eclipse, It can also happen when windows thinks there is a second monitor added when in fact there isn't. The application gets stuck on the other screen so even Maximize won't help. –  Mark Price Jan 12 '12 at 17:26
    
Thanks @Mark Price. Sorry it took so long to accept. –  therobyouknow Aug 28 '12 at 12:35
    
+1 @Eclipse for the tip about the preview and "Maximise" –  therobyouknow Aug 28 '12 at 12:36

I solved the issue whereby only one icon in the taskbar won't maximize/restore:

  1. Right-click the icon to see the pop-up menu with options (close window, pin to taskbar, name of program).

  2. Click on the name of the program. This should result in the taskbar icon flashing.

  3. Press and hold Win, and browse through opened windows by pressing Tab. You should have your software maximized again. If this doesn't work, do the next step.

  4. Win+D (pressing these keys together should refresh your desktop to original positions).

share|improve this answer

Here's how I fixed the problem.

I had one WordPad document open and it was stuck minimized in the taskbar.

I tried all the other suggestions here without success.

Because I am using Windows Classic theme, I thought to switch to an Aero theme so I might at least get a hint of what was on the WordPad document by using Aero Preview.
As soon as I switched to the Aero theme the WordPad document maximized.

So, try switching themes types (Aero -> Classic) or (Classic -> Aero) and see what happens.

share|improve this answer
  1. Click on taskbar icon.
  2. Right-click on small window and select move.
  3. Use arrow keys to move the window, most likely left arrow.
  4. Locate on a visible area, press enter.
share|improve this answer

protected by Community Jan 20 '14 at 20:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.