Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got two monitors connected to the same PC; one directly via DVI, the other through a KVM switch on a (blue) VGA cable. I just installed Xubuntu 11.10 on it, installed the current nvidia drivers, and using the NVidia X Server Settings applet, I've configured them. I'm using a TwinView configuration, so that I can drag windows from one monitor to the other, etc.

The DVI-connected monitor is recognized correctly and set to 1024x768. The VGA-connected, however, lists a slew of resolutions, but not the correct one (1280x1024). I've now set it to 1280x960, but everything is slightly blurry since it's not the monitor's native resolution. The listed resolutions are 1440x900, 1360x768, 1280x960, 1152x864, 1024x768, 832x624, 800x600, 720x450, 680x384, 640x480, 512x384.

Does anybody know how and where I can configure my machine so that the main monitor works at its native resolution?

Edit: This is currently the contents of my xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 280.13  (buildmeister@swio-display-x86-rhel47-03.nvidia.com)  Wed Jul 27 17:15:58 PDT 2011

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 280.13  (buildd@yellow)  Fri Aug  5 12:31:28 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-1"
    HorizSync       30.0 - 60.0
    VertRefresh     56.0 - 76.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "COMPAQ 1520"
    HorizSync       30.0 - 60.0
    VertRefresh     56.0 - 76.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 530"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 530"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +1360+0, CRT: 1360x768_60 +0+0"
# Removed Option "metamodes" "CRT: 1280x960 +0+0, DFP: nvidia-auto-select +1360+0"
# Removed Option "metamodes" "CRT: 1280x960 +0+0, DFP: nvidia-auto-select +1280+0"
# Removed Option "TwinView" "1"
# Removed Option "metamodes" "CRT: 1280x960 +0+0, DFP: nvidia-auto-select +1280+192"
# Removed Option "TwinView" "0"
# Removed Option "metamodes" "CRT: 1280x960 +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-1"
    Option         "metamodes" "CRT: 1280x960 +0+0, DFP: nvidia-auto-select +1280+192"
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024" "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
share|improve this question
add comment

2 Answers 2

Add it in xorg.conf directly or use nvidia-xconfig --mode=1280x1024

share|improve this answer
    
Thank you for your reply. How do I add it in xorg.conf directly? I can't see anywhere likely, except in one place where it's already listed (to no avail). I'll add the contents of my xorg.conf to the question. –  Martijn Jan 12 '12 at 17:59
    
Edit the metamodes for Monitor0 (the one called CRT-1). man xorg.conf and the nVidia documenation are also helpful. –  micke Jan 12 '12 at 23:05
    
ah, thanks a lot for the link to the docs. I'll be playing with that. –  Martijn Jan 13 '12 at 8:10
add comment
up vote 0 down vote accepted

It turned out to be relatively easy to fix.

Once I connected the monitor directly to the computer, the driver was able to read the monitor's EDID. I saved the settings, and now it works fine even when connected through the KVM switch.

The main problem was that I needed to specify different frequencies.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.