Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My problem is that most guides on the Internet I've found explain how to enable serial terminal on GRUB 1 and it appears that they moved to GRUB 2 on Debian.

I'm running Debian inside VMware and have a serial port set as named pipe com_1 and set to server and other end as virtual machine. On the other side, I'm using same named pipe and the end is set up as client and the other end as virtual machine. I've also followed this guide and the other end can't see the terminal.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Fortunately, the procedure isn't too complicated and requires only uncommenting some lines in appropriate setup files.

First the GRUB setup:

Open file /etc/default/grub with your favorite editor and make sure that is contains following lines:

GRUB_CMDLINE_LINNUX="console=tty0 console=ttyS0,9600n8"

GRUB_TERMINAL=serial

GRUB_SERIAL_COMMAND="serial --speed=9600 --unit=0 --word= --parity=no --stop=1"

Some of the above lines may already exist and need to be modified or may need to be completely added. They should also be modified to match setting which the terminal is expecting and to which serial port the terminal is connected.

Next is the /etc/securetty file. Open it and make sure that serial ports which will be used are on the list. If they're not, add them there.

After that comes the /etc/inittab file Open it and uncomment the line at the bottom:

T0:23:respawn:/sbin/getty -L ttyS0 9600 vt100

This line may also need to be edited for appropriate settings such as terminal type, speed and serial port.

After this, the bootloader needs to be updated. Command update-grub will compile the settings for grub and reinstall the bootloader. After this the system should be set.

BONUS POINTS I'm using VMware on Windows 7 host and after all this, it's not working! What should I do?

Make sure that named pipes are working properly. For that, Sysinternals program pipelist.exe is useful here. It can be obtained from here. With default settings after Windows installation, it won't list the pipes and will instead crash. If that happens, goto Control Panel->Programs and Features-> Turn Windows features on or off-> Microsoft .NET Framework 3.5.1 and enable Windows Communication Foundation Non-HTTP Activation, restart and named pipes should now work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.