Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a problem with my notebook, I can't connect to a WiFi network from my notebook.

It finds all the wireless networks around but it is unable to connect to anyone. I've tried deleting the password of the network and trying to connect without password but it didn't work either. I know that my WiFi network is working because I can connect to it from my smartphone. I also tried pinging 127.0.0.1 and I received the reply. I don't know what to do to make it works, is there something wrong with my network card? I also tried it on Linux and faced the same problem.

share|improve this question
2  
What happens when you try to connect? Do you get an error message? If so, what is it? –  David Schwartz Jan 12 '12 at 2:31
    
Was it working before and suddenly stopped working? –  CharlieRB Jan 12 '12 at 3:13
    
I don't get an error message, it only say: please wait while windows connects to the network... and in about 30 seconds the message disappears and nothing happens. –  cracq Jan 12 '12 at 3:19
    
Not suddenly... One day I turned on the computer and it didn't connect –  cracq Jan 12 '12 at 3:23
    
When you say 'connect', do you mean connect to the network itself, or in regard to internet access? FYI: Pinging 127.0.01 should work in most cases because that is an address for your computer (localhost). –  iglvzx Jan 12 '12 at 4:18
show 2 more comments

migrated from stackoverflow.com Jan 12 '12 at 2:32

This question came from our site for professional and enthusiast programmers.

2 Answers

up vote 0 down vote accepted

Have you try connecting to non encrypted network? Have you try using an external wifi adapter?

share|improve this answer
    
yes, I've tried connecting to non encrypted network and I haven't used a external wifi adapter –  cracq Jan 14 '12 at 18:40
    
If you can't get your hand on external wifi adapter then you can try uninstalling your wifi adapter in Device Manager. Then reinstall it again with the latest driver. –  chmod Jan 16 '12 at 1:50
add comment

First, check if you have the correct drivers for your network device. If not, try searching your card manufacturer's website for correct drivers.

The card not working in Linux is interesting. Your card may have some physical options (buttons or switches on the side of your notebook), or it may have firmware settings that are not controlled by the OS. Look on your card manufacturer's website and see if there is a way to change those settings if this applies to your model.

If you are still covered by warranty, send it in for replacement/repair. The makers of your card usually know how to fix things.

If all else fails, your card might be broken and needs replacement. Before you get it replaced, check if it is broken in the first place. Find a store that can figure out if it needs repairing or not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.