Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I run the 7zip commandline:

> echo foo | 7za a arc.7z -sifoo.txt

Everything works as expected, but if I try to do:

echo foo | 7za a arc.zip -sifoo.txt

I get the following:

E:\7zip>echo foo | 7za a arc.zip -sifoo.txt

7-Zip (A) 9.20  Copyright (c) 1999-2010 Igor Pavlov  2010-11-18
Creating archive arc.zip

Compressing  foo.txt    0%

System error:
No such interface supported

Any ideas why?

share|improve this question
    
Don't know if the applies here or not but (Note: The current version of 7-Zip support reading of archives from stdin only for xz, lzma, tar, gzip and bzip2 archives.) –  nhutto Jan 12 '12 at 16:48
    
supposed to say -tzip though I still get the error echo foo | 7z a -tzip r.zip -sifoo –  barlop Jan 13 '12 at 2:59
    
and probably supposed to put switches between command and archive name, though still get the error. but no doubt you should use -tzip for zip. So this works for example, no echoing though >7z a -tzip r.zip a.a But doing >echo text | 7z a -tzip -sia.a r.zip gives the error. so your question stands. And you mean 7z a, not 7za. –  barlop Jan 13 '12 at 3:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.