Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I find that when I paste excerpts from my text editor (width 100) into the thunderbird compose window it is truncated to width 80 or so by the time it gets to the receiver. Within the compose window itself, there is no truncation. I can verify this by sending the Email to myself. I am not sure if these extra end of line characters/formats are inserted before sending or on receiving. Is there a way to tweak this behaviour so that the width of my Emails are always 100?

share|improve this question

2 Answers 2

You can change the number of characters per line by changing the prefs value mailnews.wraplength. By default it contains the value 72. Change it to 100 and plain E-Mail messages in the composer will be wrapped at column 100.

See also Thunderbird Mail and news settings and Modify Thunderbird settings.

The Config editor can be opened via: Tools → Options → Advanced → General → Config Editor

share|improve this answer
    
Thanks for the link, though it seems to apply to an older version of Thunderbird. 8.0 version doesn't have tools->options menu and I can find no reference to a config editor for this version. –  SetJmp Jan 13 '12 at 16:40
    
@SetJmp see my updated answer –  Robert Jan 13 '12 at 19:22
1  
@Serge Stroobandt: Which version of Thunderbird are you talking about. In Thunderbird 31.6 (Windows) the Config Editor is still available through the path mentioned in my answer. –  Robert Apr 30 at 14:56
    
@Robert In the GNU/Linux version of Thunderbird 31.6.0, the menu structure appears to be slightly different. Under Linux, the GUI path to open the configuration editor is: Edit → Preferences → Advanced → General → Config Editor –  Serge Stroobandt Apr 30 at 15:24

One can even have the wrap length adapt automatically to the window width. To do so, open the configuration editor (shown here for the Linux version of Thunderbird):

Edit → Preferences → Advanced → General → Config Editor

Then, set mail.compose.wrap_to_window_width to true.

Caveat

If you use Thunderbird with an External Editor, then of course will need to properly configure that editor as well. For example: If you are a Vim user, you would add the following line to your .vimrc file to prevent default textwidth wrapping:

autocmd FileType mail setlocal textwidth=0
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.