Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tend to log in to my user session on Windows7 machine locally. However at times I do connect from remote location.

The problem starts when I try to restore Firefox app window. I cannot see its content.

I tried Windows + left, windows + right .. etc keys. They only move around part of the content of the application window that was shown before activating Firefox. Meaning Firefox windows does not get refreshed.

I have had this problem for quite a while now. I can tell for sure that it is present in FF8, FF9 and after recent update to FF10

Anything I could try?

EDIT: it seems that I can kill firefox and when I restart it UI starts to work. The problem is then that even if my session luckily restores (which often does not happen), it takes awful lot of time to restore hundred tabs, not mentioning loosing state of some of them.

share|improve this question
1  
Did you try to deactivate Persistent bitmap caching in the settings of your RDP session? –  Alexander Galkin Jan 12 '12 at 22:33
1  
Do you have multiple monitors locally but not remotely, or are the monitors different sizes? Is FireFox in the Taskbar? –  shufler Jan 12 '12 at 22:44
    
@AlexanderGalkin - I have just disabled it and tried in couple of connection speed settings but it does not get better. –  user377178 Jan 13 '12 at 11:54
    
@shufler - I have one or two monitors locally (depends) and just one remotely. The monitors are of different sizes (remote monitor has different resolution than each of the local ones, which in turn differ themselves). Firefox windows are listed on the taskbar and not minimized when I connect remotely. –  user377178 Jan 13 '12 at 11:58
1  
Why does the local machine sometimes have one monitor and other times two monitors? When connecting remotely is there always one or two attached (to the local machine) or does it differ? –  shufler Jan 13 '12 at 17:30

1 Answer 1

The problem is almost certainly due to hardware acceleration. This is available when you log in directly, but is often not available if you log in remotely. Or it might be available for both, but Firefox can't easily switch acceleration between two different graphics cards.

While it is possible that later versions of Firefox have fixed this issue, I will tell you how to work around it, just in case.

When you are logged in directly, go to Firefox > Options, and then click the "Advanced" tab. Under the "General" sub-tab, make sure "Use hardware acceleration if available" is unchecked. Restart Firefox to ensure the setting takes effect.

share|improve this answer
    
yes, that is how I deal with this currently. Chrome seem to have had similar issue last time I checked –  user377178 Oct 14 '13 at 11:23
    
Well, then, you might not know that restoring your session should not take anywhere near as long as it used to, as Firefox will not actually load all 100+ tabs. So, if you don't like having acceleration disabled, you could go back to the restart method you mention in your question. –  trlkly Oct 17 '13 at 10:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.