Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've downloaded and configured with a minimal configuration file. I'm running Squid 2.7 on a Windows box. I've configured a client machines' browser to use my proxy server, but all external DNS queries don't work (i.e. www.google.com doesn't work but a local name works fine). Here's the error page I get:

The requested URL could not be retrieved

While trying to retrieve the URL: http://www.google.com/

The following error was encountered:

    Unable to determine IP address from host name for www.google.com 

The dnsserver returned:

Refused: The name server refuses to perform the specified operation. 

This means that:

The cache was not able to resolve the hostname presented in the URL. 
Check if the address is correct. 

Your cache administrator is ##################.
Generated Thu, 12 Jan 2012 22:34:15 GMT by ######## (squid/2.7.STABLE8)

I think I have an unusual network setup, like this:

                           router
                       ____/    \____
                      /              \
internet ---- my proxy server      client PC

Does my setup have something to do with it? Any suggestions as to how to solve the problem? Thanks

share|improve this question
    
If you ping google from.com the squid box does it resolve? –  Paul Jan 12 '12 at 22:52
    
Yes. Also, from the client machine, I can request google's IP address through the proxy and it works fine. –  phillid Jan 12 '12 at 22:59
    
Ok, can you check if you have any dns_nameserver entries in the squid.conf file? –  Paul Jan 12 '12 at 23:04
    
No, I don't. Should I put some in with my ISP's nameservers' IP addresses in it or something? –  phillid Jan 12 '12 at 23:07
    
Yes, I just did it, thanks :D I knew I'd missed something simple like that... Oh well, I ges this question may be found by someone else in the future and save them asking the question too –  phillid Jan 12 '12 at 23:10

1 Answer 1

up vote 3 down vote accepted

On a Windows machine, if squid is not told to use specific nameservers in squid.conf, it should use the system nameservers by interogating the registry. This can be seen in the cache.log, when searching for "Adding nameserver".

If this doesn't work for any reason (sometime it will incorrectly choose itself as a nameserver - 127.0.0.1), you can add specific name servers in squid.conf:

dns_nameservers 8.8.8.8 208.67.222.222
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.