Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have Acer Aspire 5520G laptop. I turned it down yesterday and today when I wanted to turn it on it wont boot up. When I press power button it lights up ( green) there is some blinking of HDD led and you can hear the noise of fan spinning. Unfortunately that's it, there is no POST screen or anything else. It's just sitting like that and after few moments HDD led turns of too so only power led remains turned on. Fan turns down too but it turns on after some time and then off again and on again.

I tried taking out battery and removing power cable, then holding power on button for 60 second and then connecting only power cable back but same thing happens. I even opened it up and cleaned all part and disconnected CMOS battery for 30 second. But, still nothing.

Any suggestions would be appreciated.

P.S. I found some people talking talking about re-flowing their laptop parts but symptoms are different from what I saw. They are mentioning flashing power led light. Nothing flashes at my laptop.

share|improve this question
    
Do you have access to an external monitor you can try it with? –  Paul Jan 13 '12 at 0:14
    
I have tried to connect laptop to external monitor but no luck. –  Lucije Jan 13 '12 at 0:27
    
Have you tried taking out the HDD or RAM to see if you can boot into the BIOS screen? –  Nick Jan 13 '12 at 16:07
    
Yes, I removed HDD, RAM, GPU and CPU. In each case I get same result. Actually when I removed CPU the power on button started to flash instead of lighting green continuously. ps. I wound on internet that this is common problem with acer laptop and it has something with overheating and connections on GPU and other chipsets on MBO. –  Lucije Jan 13 '12 at 18:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.