Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Notepad++ and to speed up the development of my program I added a keyboard shortcut to the Run menu. This of course took a few tries to get right and now I have multiple entries on the list which read

Compile     Ctrl+Shift+S

Most of which don't work due to failed attempts. Is there any way to remove the extra commands?

share|improve this question
up vote 7 down vote accepted

Under Settings go to the Shortcut Mapper. You should see a tab for run commands. Right-Click delete to remove the undesirable run command.

More documentation about formatting run commands can be found here.

share|improve this answer
    
On a side note, is there a way to incorporate the currently opened file into the command? i.e: ghc -O2 --make <CURRENT FILE> – Jonno_FTW Sep 8 '09 at 14:43
1  
In the Help Documentation it will tell you to use $(FILE_NAME) for that – jweede Sep 8 '09 at 14:48
    
Can you provide a link to the documentation that documents $(FILE_NAME). The standalone chm file has no such references. – Ian Boyd Mar 11 '11 at 23:33
1  
@Ian I've added a link as requested. Hope this helps! – jweede Mar 13 '11 at 19:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .