Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm on a Mac Mini 2011 with VirtualBox installed. I have Windows 7 running as a Guest OS.

My question: How do I "trap" my mouse pointer within Windows? In other words, I don't want my mouse to move outside to the Host OS. Ideally, I would be able to press the Host key to "untrap" my mouse.

The purpose: I'm playing Warcraft 3 in the Guest OS and I can't scroll the screen since the mouse keeps jumping to the Host OS instead of scrolling the screen. This happens even in full-screen mode.

share|improve this question
up vote 10 down vote accepted

Select Disable Mouse Integration from VirtualBox's Machine menu. Next, click within the guest OS to capture the mouse.

capture

share|improve this answer

Use this command to make it permanent.

VBoxManage modifyvm "your-vm-name" --mouse ps2
share|improve this answer
    
This works with newer versions of VirtualBox – sshakir Jan 12 '15 at 6:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .