Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I've purchased new ASUS ENGTX560 DC/2DI/1GD5 and installed it on my ASUS Maximus IV Gene-Z motherboard. My motherboard has onboard graphics card with HDMI output as well and before it was fine, but after I connected my 23 inch monitor to the new graphics card part of my monitor isn't used until drivers are not loaded. So BIOS, console, windows installation and even windows (when driver is not installed) uses part of display and doesn't scale image to fit my monitor. Max resolution I was able to set from windows was 1280x1024. As soon as I install drivers it works fine, but BIOS and console are still running with that black frame. What's that? How to solve the problem? I don't even know what to google. Thanks in advance.

share|improve this question
    
My answer has been edited to reflect the new info –  geocoin Jan 13 '12 at 13:00

4 Answers 4

In your BIOS you must have an option like that:

Auto-Adjustement OR Fit To Screen

Try Changing DIV to VGA and vice versa

share|improve this answer
    
I didn't see any setting like that in my BIOS and my graphics card doesn't have VGA output. It has 2 DVI and one mini HDMI output, but both give me same result. –  axe Jan 13 '12 at 7:38
    
You got the Replublic Of Gamers BIOS ? –  bZezzz Jan 13 '12 at 7:48
    
What do you mean? Maximus IV is a RoG motherboard, so the BIOS is RoG. –  axe Jan 13 '12 at 7:53
    
Yes but you could have flash it ! ^^ I will look on mine, but I think It's a screen problem... Too big ! –  bZezzz Jan 13 '12 at 7:54
    
no, I haven't done any bios changes. Also this screen works without any problem when connected to the onboard graphics card, so if it's not too big for simple onboard 64Mb Intel HD Graphics, then I suppose it shouldn't be too big for ENGTX560 :) –  axe Jan 13 '12 at 7:55

It could be the scaling setting in the graphics driver utility; in the past I've found that that setting is somehow persisted and then affects the display during boot time (e.g. BIOS, the windows loading screen). If it's set not to scale, that would cause the screens to be shown letterboxed, with the resolution pixels 1:1 with your monitor's native pixels.

Even if it's set to scale, maybe scaling up to the size of the new monitor is beyond the capabilities of whatever is set to do the scaling, in which case you should at least try the other scaling choices if there are some.

NVIDIA Cards:

Go to NVIDIA Control Panel, from the Display part of the tree choose "Adjust desktop size and position", select the display, choose one of the scaling choices (Use NVIDIA Scaling, Use NVIDIA scaling with fixed-aspect ratio, Use my display's built-in scaling)

Similar settings for people with AMD/ATI cards: (this is probably out of date)

Go to Catalyst Control Panel, select the digital display, go to Attributes, and check the option to Enable GPU Scaling.

share|improve this answer
    
When windows and VGA driver are loaded it works fine, it doesn't scale to the monitor in BIOS or console or anywhere else, where graphics driver is not loaded. –  axe Jan 13 '12 at 11:10
    
Like I said, once you set a scaling setting in the driver utility on some cards it persists even when the driver isn't loaded. –  rakslice Jan 14 '12 at 7:19

sounds like a combination of the driver scaling non-native resolutions up to native ones, and the monitor itself not scaling non-native images. usually it's the other way round, the monitor will only scale non-native sizes.

there is usually an option listed as '1:1 pixel mapping' or 'scale all sources' or similar. without knowing your monitor make and model it's hard to know, as different manufacturers use different terms. edit: on the NEC AS231WM it's called "expansion" in the 'TOOL' section (page 10 of http://www.necdisplay.com/documents/UserManuals/AS231WM_UserManual.pdf )

when it's plugged into the onboard GFX, go into the monitor menu and look for the info display where it displays the current resolution. If it shows the native resolution as the current res while you're in the post screen and early boot up then it's scaling before it gets to the screen. see what it displays when you have it connected to the GTX 560 in the same part of the boot sequence (when it has the black bars)

compare and contrast. The POST screen should always be something low like 640x480. it's then scaling which makes it fill the screen either in drivers, output hardware or by the monitor itself.

share|improve this answer
    
It's NEC AccuSync AS231WM –  axe Jan 13 '12 at 11:14
    
it seems (from the user manual) it's called "expansion" in the menu. and the icon is of a magnifying glass with a '+' inside. options are 'Full' and 'Aspect' (and possibly 'off'?) change this setting and see if it affects the results in the way you are looking for –  geocoin Jan 13 '12 at 12:53
    
geocoin: I was looking for something like that in the monitor menu, but wasn't able to find, I'll check it out today and let you know. Thanks. –  axe Jan 16 '12 at 6:36
    
I set this option to Full, but it shows the same thing, no difference. It still shows picture like that (img15.hostingpics.net/pics/115127photo.jpg) –  axe Jan 18 '12 at 21:13

Note the default (read as "have to be used") resolution of your monitor: 1920x1080

Better will be to select this resolution (in own monitor settings, not in Windows at 1-st step), positon|resize image with hardware controls.

PS: Maybe, monitor driver also will be useful (for Windows, obviously)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.