Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is on CS5.5 under Windows XP Professional.

There seems to be a known issue about saving (large) Adobe Illustrator files to PSD (thoroughly discussed), where the exporter will complain about "Not enough memory to save the file". This happens regardless of the available memory on the computer, and seems to be a limitation in the PSD exporter itself.

The only possible solution so far seems to be to copy-n-paste each layer separately from the illustrator file and into the open Photoshop file. We need to keep the layers intact (and not merged), so selecting all the layers at the same time doesn't work.

Do anyone have a workaround to the actual, original export issue, or a way to be able to get the layer information into Photoshop without handling each layer separately?

share|improve this question
1  
Actually your rude answer is ill informed. Val was correct and this is a working solution. So before you jump on your horse, check your flaming is valid. –  user129795 Apr 23 '12 at 13:32
add comment

6 Answers

Unchecking Anti-Alias seems to work, unfortunately it gives unsatisfactory results in my opinion. You lose the crispness on the edges of artwork without anti-aliasing.

share|improve this answer
    
Yes, that works - but lacking anti-aliasing it is (as you note) completely unusable for any partical use. :/ –  fiskfisk Apr 30 '12 at 20:20
add comment

You can try the following. Go to: Edit > Preferences > Performance and change the amount of memory that is assigned to Photoshop by moving the slider to the right. Check also that you have enough space on your scratch disks.

share|improve this answer
add comment

when exporting as psd from AI, after clicking save, "photoshop export options" dialog box opens. Make sure anti-alias box is UNCHECKED. That did the trick for me!

share|improve this answer
add comment

Flip your picture on it's side and try exporting it. Worked for me - apparently there's a problem exporting files that are too wide, but too tall isn't a problem. Sounds silly but it was the only solution that worked for me. :)

share|improve this answer
add comment

While there's been a lot of good suggestions, I've been unable to make any of them work satisfactory (such as turning of anti-aliasing which isn't an option). Rotating the image is also an issue as long as the image is almost quadratic. Anyway - CS6 64bit seems to have solved the issue, and exporting under CS6 currently work with files that CS5.5 refused to export!

share|improve this answer
add comment

(for Windows 7, 64 bit... not sure if it'll work with other operating systems) to go to the illusrator.exe file via the programs folder on your pc. Right click the illustrator.exe file and click properties. Go to the 'Compatibility' and tick the box that says "Run this program in compatibility mode for:" and select 'Windows XP (Service Pack 3)' from the drop down menu. Apply and click ok. It also worked when I checked Windows Vista Service Pack 2 also.

Once I had done the above, i opened up illustrator (using CS5 and 5.5) and tried to export the Ai file again and it worked! AND You DO NOT need to uncheck anti alias.

found this answer in the Adobe Forums by Marie

share|improve this answer
2  
The author of this question does not have a 64-bit operating system. So your answer with regards to a 64-bit operating system seems sort of pointless. Your suggestion basically suggests that they run it in Windows XP compatibility mode, when the user is running Windows XP, a clear indication you didn't even read the author's question. Futhormore, the suggestion is sort of silly, considering those programs have no problems by default running on Windows 7. Futhermore suggesting Vista compatitability mode is down right stupid for a user using Windows XP. –  Ramhound Apr 6 '12 at 16:03
    
Tried it at CS5.5 Windows 7 64bit with compability mode active, didn't work with the current file giving problems. –  fiskfisk Apr 30 '12 at 20:21
add comment

protected by Community Oct 23 '12 at 1:54

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.