Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Recently I replaced my old Radeon HD 2600XT to Radeon HD 6770 from MSI.

I had strange problem that after installing the newest Radeon drivers they exist only until first reboot. After reboot my new card is recognized as an old 2600.

I tried to unintall ATI/AMD software completetely from Programs/Features, then reboot, then untinstall driver from device manager, then reboot, then system showed that display driver is regular VGA (and oldschool 640x480 resolutions). Then to be double sure I executed DriverCleaner3 and Driver sweeper. After the restart I installed the newest drivers from amd site but after restarting the system recognizes card as 2600.

I'm completely lost. Perhaps Win7 64bit caches somewhere drivers? Are there any issues regarding drivers-shadowing or 32/64 mirroring?

Reinstalling the system is not an option.

share|improve this question
    
You could try and run ccleaner piriform.com/ccleaner –  bamboon Jan 13 '12 at 19:50
    
Or unistall it with: freenew.net/windows/iobit-uninstaller-2-0/68873.htm –  bZezzz Jan 13 '12 at 19:54
1  
You SURE you didn't put the 2600 back in (have to ask)? Have you tried manually assigning the drivers to the card after it's detected as a 2600? –  Ƭᴇcʜιᴇ007 Jan 13 '12 at 22:12
    
Best video driver cleaner there is...drivercleaner.net –  Moab Jan 13 '12 at 23:03
    
Yes I'm sure that newer card is inside. –  tomo Jan 17 '12 at 23:13

1 Answer 1

  • Download Driver Sweeper from - http://phyxion.net/item/driver-sweeper.html
  • Install DriverSweeper
  • Uninstall your Radeon drivers from the Control Panel > Programs and Features
  • Reboot your system into safe mode (Hit F8 during Boot)
  • Run DriverSweeper (from within Windows Safe Mode)
  • Check on "AMD-Display"
  • Hit Analyze
  • Select All and Hit "Clean"
  • Reboot back into Normal Windows (not safe mode)
  • Install your new drivers
share|improve this answer
    
Looks like Driver Sweeper is now Driver Fusion. The current link points to a redirect to this link: treexy.com/products/driver-fusion –  Randolpho Oct 25 '12 at 1:44
    
Driver Sweeper got replaced by Driver Fusion. The free version doesn't have all the features. I tried to use it and it said it couldn't completely clean all of the files and to purchase the premium version (~$20). But you can find the old version of Driver Sweeper for free and it looks like it does not have its features limited. I downloaded and ran it after running Driver Fusion and it found a bunch of registry keys. techspot.com/downloads/4266-driver-sweeper.html –  Harrison F Jul 13 '13 at 17:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.