Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A few days ago I wanted to connect additional devices to our home network. Sadly, the walls in this apartment have a very bad influence on our WLAN performance.

Our main, host WLAN access point is a Netgear WNDR3700v1 (loaded with DD-WRT v24-sp2) which is located on one end of the apartment. So my plan was to increase the range of the network with a WLAN expander. I set up a TP-Link TL-WA730RE which works great.

In the second step I wanted to set up another WLAN access point in bridged client mode to allow me to connect additional devices by wire on the other end of the apartment. I used a Linksys WRT54GL (loaded with DD-WRT v24-sp2).

Sadly, the WRT54GL does not seem to connect to the network. If I connect a client to it by wire, I can only reach that single access point and nothing else on the network.
But if I then turn off my range expander (and, thus, make the WRT54GL connect directly to my WNDR3700v1) everything works just fine (signal strength is in the 1-digit range, but nevertheless).

So I would assume all wireless related settings are correct. The expander can connect to the host just fine and performs well. The client access point can connect to the host just as well. This issue is horrible to debug as the applications being used by DD-WRT can't supply any output whatsoever. So even if they would usually spit out an error message maybe, they don't. Leaving me clueless as to what the problem is.

share|improve this question
add comment

1 Answer 1

up vote 2 down vote accepted

You are most probably running the netgear in mixed mode G/N. If that is the case, it may be that the tplink repeater cannot run in mixed mode and broadcasts the signal in N-mode only, which is why the WRT54GL can connect to the Netgear but not to the repeater (since the wrt54g is B/G only). If you want to use the linksys, try running everything in pure G mode.

share|improve this answer
    
Thanks a lot. After setting both DD-WRT routers to G-Only, everything connected just fine. –  Oliver Salzburg Jan 14 '12 at 16:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.