Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running OSX Lion as host and using VmWare Fusion 4 and the guest OS is Ubuntu 11.10 - all of my dev tools are on the guest OS, and the files are on MacOS - so I can use my IDE's on Mac and other stuff....

I am trying to setup a mount on the guest OS by editing /etc/fstab

I've got this in there.

//192.168.75.1/mysharedfolder      /mnt/sharedfiles cifs     user=USER,password=PWD,nounix,noserverino,sec=ntlmssp 

I can list the contents for the /mnt/sharedfiles by doing this but everything is read-only. How can I give it full read/write control?

Any ideas?

share|improve this question

migrated from serverfault.com Jan 14 '12 at 14:41

This question came from our site for professional system and network administrators.

add comment

1 Answer

I arrived to your question because I googling about the problem with OSX Lion when exporting shares to (Linux) samba clients. You already figured out the hard part, that is, when mounting smb shares from Lion you have to use the options nounix,noserverino,sec=ntlmssp otherwise the client will not work.

Permissions should now be a much easier matter. First, note that by using nounix the uid/gid/modes of files will not be communicated from the server to the client. So you have to give them some value on the client side, say uid=1000,gid=1000 (use your Linux user values).

Same thing with the file and dir modes, they are not communicated between the two sides, so they are just "faked" on the client side to whatever you want, so using something like file=mode=0644 and dir_mode=0755 will make everything appear OK on the client side.

On the server side (OSX) the files will be owned by the user that you used to make the SMB connection and their permissions will be whatever OSX uses as default mask, I guess.

share|improve this answer
    
Thanks for the reply. I added this ,uid=1000,gid=1000,file_mode=0755,dir_mode=0755 to fstab mount command and I still get no permissions error when I try to do ls -l on the /mnt –  Jimmy Jan 28 '12 at 18:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.